ActiveX control disabled in excel 2003 with security updates

Good evening!

I have both excel 2003 and excel 2010 loaded on one computer at work ( windows 7) and had an automatic security update that only affected excel 2003.
Buttons associated with some of my macros in excel 2003 are grayed out and cannot be re enabled. I cannot set a new button and associate it with that macro
Excel 2010 still works fine. I am curious as to why this should have happened at all? The excel 2003 is kept for some users who use it sporadically and who prefer that Excel version. The macros can be used in excel 2010 though there are no macro buttons, and it is that features that is for some users the attraction of excel 2003. s
I would really appreciate some insight as to what might have been changed and what might help!
Many thanks!
Danièle
Daniele QuestiauxResearch associateAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

btanExec ConsultantCommented:
Possibility:

a) Sometimes, the workbook probably has a macro that is running when the workbook is opened
that is disabling the menu option. Try using Alt-F11 to see if you can get to the VBA menu. Also the VBA Project may be protected with a password that disallow others to make changes.

b) Options could be disabled by group policy settings controlled by your domain admins. Will requires permission from your IT team to make any "re-enable" change. May need to clarify with them. Otherwise there is local policy as well. Regardless, for GPO, e.g. via GPEDIT.MSC (in the Run box), you can navigate to below to check for the enabled state and Disable this setting if it is enabled.

User Configuration/Administrative Templates/Microsoft Excel 2010/Excel Options/Security/Trust Center/Trusted Locations/VBA Macro Notification Settings Enabled

c) Another area is the Trust Center security level setting e.g. Very High, High, Medium, and Low. For 2003, it should be in ‘Tools’ tab > ‘Macro’ > ‘Security’.  It will show you all the security levels that you can select for your macros. See the reading in tbl for the level - I do suggest Medium though you can test out  Low to clear out the issue to see if is the culprit.
* "Low" is definitely not recommended unless you have a virus scanner running and are 100% certain of a document's authenticity.

* "Medium" lets macros run, but if Excel 2003 determines them to possibly have unsafe code, you will be prompted. Note that Excel 2003 may not always detect unsafe code.
* "High" only lets macros from trusted sources run. You can click the "Trusted Publishers" tab to view the list of such sources.
* "Very High" only lets macros run from trusted locations and from trusted sources.
https://support.office.com/en-us/article/Change-macro-security-settings-in-Excel-a97c09d2-c082-46b8-b19f-e8621e8fe373#__toc272500834

Other  points to note

You may also need to add a macro publisher to the "Trusted" list, set the macro protection to "Medium" or "High". Load a file containing macros you wish to run. You will then be prompted to add the publisher to the trusted list. Note that macros must be digitally signed by a publisher or this option will not appear.

For 2013, the macro setting is via trust center and has even configuration that can allow running of a macro even if all macros are disabled, provided those are residing in the listed trusted locations below:
Program Files\Microsoft Office\Templates
Program Files\Microsoft Office\Office12\Startup
Program Files\Microsoft Office\Office12\Library
Program Files\Microsoft Office\Office12\XLSTART
See more on 2013 macro controls in https://www.ablebits.com/office-addins-blog/2014/07/22/enable-macros-excel/
0
jcimarronCommented:
What might help?
Run System Restore to a date before the security Update was installed.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
btanExec ConsultantCommented:
May be also due to this MS advisory on this "symptom" though it stated in context of Powerpt and Words, but still boils down to Macro being disabled or grayed...the resolution is as shared in my earlier post to adjust trust level or go for digitally signed or Trust all installed add-ins and templates etc
By default, Office sets macro security to High. This setting prevents Visual Basic for Applications (VBA) sub procedures and add-ins that have not been digitally signed from running.
https://support.microsoft.com/en-us/kb/285514
0
How do you know if your security is working?

Protecting your business doesn’t have to mean sifting through endless alerts and notifications. With WatchGuard Total Security Suite, you can feel confident that your business is secure, meaning you can get back to the things that have been sitting on your to-do list.

Daniele QuestiauxResearch associateAuthor Commented:
Thank you for all the help, and sorry to reply so late.
I have been ill for several months and am back hopefully for a while and rearing to get back to work.


The issue I believe in my case is that i have both versions in one computer so that the tricks did not work, but when I did  a system restore on my old computer that had the older version ONLY, that worked. This shows that one should not linger on with older versions and definitely not have them on the same computer!

Many thanks!
0
btanExec ConsultantCommented:
Do take care. Thanks!

Also for your consideration:  Since the restore work rather than the setting, you may want to also award jcimarron as well. The macro setting is sound as verified just that the different version in same notebook creates such symptoms inadvertently.
0
jcimarronCommented:
btan--
Thanks for your courtesy.
0
Daniele QuestiauxResearch associateAuthor Commented:
Dear btan and jcmarron,

I am sorry to have left out btan from the rewards and thank you for pointing that omission as it was really un called for.
I am really sorry and am not sure how I can correct that?

Thank you for your kind wishes. I am on the mend definitely and am glad I never realised it would take so many months to get back on track. It is then nice to see how the help you can get from people like you both really helps and really brings a lot of comfort and I am getting back on the links you shared to try and grasp a bit more, even if I am now quite firmly going forward and leaving excel 2003 behind.
 
Thank you!

Danièle
0
jcimarronCommented:
daniques--
Actually you gave the full award to btan, but left out jcimarron.

You can change this by clicking the Request Attention button at the bottom right of your original post and asking for the change.  

I hope everything is well now that you are back to work.
0
btanExec ConsultantCommented:
Thanks daniques and jcimarron
0
Daniele QuestiauxResearch associateAuthor Commented:
The problem persisted on that computer probably because there were 2 versions of excel installed?
The system restore to an earlier date on another computer worked, but the comments about 2013 configuration allowing macros has been duly noted!
Thanks!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
OS Security

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.