Cannot RDP from a home network to a business network

Have a couple customers that cannot remote into their work computers from home. One customer could about a week ago but now cannot. Nothing has change at her home and the OS is Win 7 pro. The other customer has Win 7 Home Premium. Is the residential ISP blocking RDP traffic.
LightWireAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Thomas GrassiSystems AdministratorCommented:
Do they have a good vpn connection established?

What message are they getting?

Make sure they do not have the default gateway checked on the VPN connection network properties.
andreasSystem AdminCommented:
Any error message?
JohnBusiness Consultant (Owner)Commented:
Is the residential ISP blocking RDP traffic <-- Not likely in my experience but you could ask them.

One customer could about a week ago but now cannot. Nothing has change at her home

It would probably still be working if this were true. On the computer do a TCP/IP Reset and DNS flush.

Open cmd.exe with Run as Administrator
Then  netsh int ip reset c:\resetlog.txt
Also, ipconfig /flushdns followed by net stop dnscache followed by net start dnscache
Then restart the computer

Then do a reset of the home router. Check the main router settings for DNS and see if an alternate DNS (say 8.8.8.8) works better.

The other customer has Win 7 Home Premium   <-- Have them upgrade to Windows 7 Pro.
Acronis True Image 2019 just released!

Create a reliable backup. Make sure you always have dependable copies of your data so you can restore your entire system or individual files.

Andy MIT Systems ManagerCommented:
I would start with some basic diagnosis which should indicate where the problem lies:

1. Can anyone else log on via RDP to the affected machines in the workplace? If not, the problem may be with the work machines/network. If yes then it's unlikley an issue with the work network.
2. Can those users rdp onto any other systems at the workplace? If yes, the problem is not with their home systems. If no, there may be an issue with their home computers.

It's very unlikley an ISP would block traffic for a particular port (unless there's some major issue) - do both users have the same ISP? It's more likely a block on the firewall/router if the port is blocked.
LightWireAuthor Commented:
The one laptop that did work I checked it out the day earlier on a business network externally so I know it works. There is no way the other is going to upgrade her OS. Besides why would it work but now not at their home. Anywhere else will work. The laptop home all ports going out is open. Going to check the home premium router today.
it_saigeDeveloperCommented:
I agree with the other experts here.  The problem is most likely not on the client side (the OS of the client computer does not matter, just the RDP version.  You can connect to a system that allows for RDP connections from any OS that supports the RDP client).  In this case I believe the required RDP client is 7.1 or lower (assuming the work computer is Windows 7 SP1 or Server 2008 R2 SP1).  But just for the sake of sanity, ensure that the client does not have a firewall that is blocking the requests.  Also make sure that they are attempting to connect to the correct RDP address.

-saige-
CompProbSolvCommented:
If I read you comments correctly, there is a laptop that won't connect with RDP when at a specific user's home, but does connect when at another location (still separate from the Host's location).

I would conclude that there are two possibilities: the router at the user's home is blocking the needed ports (look at Firewall settings in the router) or the system at the receiving end is only allowing access from specific IP addresses (far less likely).

As others have suggested, it would be helpful to know what happens when you try to connect from the home location.  Specifically, what messages do you receive?

Another test of interest would be to ping the host external IP address from the home location (that doesn't connect with RDP) and from the business location (that does connect with RDP).  I'm betting both will have the same result, but it is an easy test.
LightWireAuthor Commented:
I guess the best will be to run over to their house and see if I can remote in since I know that my connection works.  I'll keep updating.
Thomas GrassiSystems AdministratorCommented:
First thing to test when you get there

1 VPN connection
2. VPN settings make sure default gateway not in use on the Von connection. Ipconfig /all

3 ping devices trying to rdp to

4 rdp. What error displays would be helpful too
LightWireAuthor Commented:
There is no VPN connection.  It's a straight and simple RDP connection to the pub IP of the office with the port redirected on the PC for the RDP session.
JohnBusiness Consultant (Owner)Commented:
If you think the computers are OK, reset (full reset) the router and set it up again. Then test.
Thomas GrassiSystems AdministratorCommented:
Not having a VPN connection to your company network leaves you very exposed

VPN traffic is all encrypted and very secure

You should look into your company router and setup VPN

Rdp works flawlessly over VPN

What type of router do you have?
LightWireAuthor Commented:
I had to have the users reset or call their ISP to reset their modem and it worked.
LightWireAuthor Commented:
I've requested that this question be closed as follows:

Accepted answer: 0 points for lightwireinc's comment #a40753086

for the following reason:

by resetting their modems allowed them to connect
JohnBusiness Consultant (Owner)Commented:
I suggested above that you reset the modem and you say it worked (http:#a40738888) and I think this solution should be accepted.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
LightWireAuthor Commented:
They had to call their ISP to reset the modem for some reason it had to be done on their end.  Power-cycle did not work.
LightWireAuthor Commented:
rest
JohnBusiness Consultant (Owner)Commented:
Thanks for following up. Cheers.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 7

From novice to tech pro — start learning today.