Unable to setup Exchange 2010 Edge Sync

I am trying to setup and Edge server , I have completed Edge install and in the process of creating the Edge Subscription.
I ran the command New-EdgeSubscription -FileName "C:\EdgeServerSubscription.xml , I got the usual "confirm" response and when I say yes with y I get the error :
New-EdgeSubscription : The command coouldn't add the certificate to the AD LDS directory service store.Error: Access is denied.
I have searched on the web for solutions and some say to create the certificate which I have done but still not luck.
Any corrective suggestion will be higly appreciated.

Thanks

J
jenkibabaSystem AdministratorAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Manikandan NarayanswamySecurity Specialist & IBM Security GuardiumCommented:
Hi,

Is your DNS suffixes are proper. Did you install ADLDS before installing edge transport server. There is a technet article written on the same i would recommend you to refer this. Also while opening the exchange management shell did you right click and select Run as Administrator if not please try that

https://technet.microsoft.com/en-us/library/ff360560(v=exchg.140).aspx

Thanks
Manikandan
0
jenkibabaSystem AdministratorAuthor Commented:
Hi Manikandan,
Thanks for your response. Yes I have the properper domain suffixes and I installed ADLDS before installing the Edge Role. I have also tried the steps in the link on your reply and It still the same result.
Thanks
J
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
jenkibabaSystem AdministratorAuthor Commented:
Hello,

I did a reboot of the server (which I had done a couple of times) and ran all the commands again runnin gas Administrator and it all worked. Your response is highly appreciated.

Thanks

J
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.