NAS home network problem

Hi all,

In my upstairs office, I have a Netgear D6200 router connected to an external fiber optic service.

Attached to this router, I have the following devices connected via Ethernet cable:

1 x Win7 Desktop PC
1 x QNAP NAS TS420 (Dual Ethernet ports)
1 x TP Link TL-PA411 powerline adapter

Connected to the powerline adapter above is one TP Link TL-WPA4220. It is located downstairs and plugged into the same electrical circuit as the above.

Now, when I use my Win7 desktop pc upstairs, I can access my NAS directly via Windows without any issues.

However, with my downstairs laptop which is connected to the powerline adapter TP Link TL-WPA4220 via Ethernet cable, I cannot access it at all.

Has anyone got any tips on how I can resolve this issue without running a cable from the router all the way downstairs to my laptop?

Thanks,
Lai
Laila JacksonAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

arnoldCommented:
Confirm IPs/netmasks/default gateway. On the NSA. And the two systems, to make sure you o not have a netmask typo such that the NSA range is such that the downstairs system is outside its segment range.
Are you able to access the upstairs windows 7 system from the downstairs system?

If not mistaken, your power line feed speed is 100MB?
0
Laila JacksonAuthor Commented:
Hey,

Thanks for reply.

Can you explain a bit more what you mean by "Confirm IPs/netmasks/default gateway. On the NSA. And the two systems,"?

Do I need to check something specific on the NAS?

My Powerline is AV500 but it has 300mbps.

Lai
0
arnoldCommented:
Lai,

Yes, checking the nas to make sure it has the same IP segment as the system downstairs.
I.e. NAS 192.168.0.5 netmask 255.255.255.0 and the upstairs system is 192.168.0.100 netmask 255.255.255.0
Downstairs system 192.168.0.128 netmask 255.255.255.0

Are you accessing the NAS downstairs by IP or by name? Reason for asking this, while the upstairs system might be able to discover the NAS by name, the downstairs system might not.


If they have the same segment/netmask, one thing to check on the NAS access/share access to make sure what range is allowed access to make sure the downstairs IP was not excluded. Another option to try is to statically set an IP one off the upstairs one making sure the it is not clashing with existing IPs in use to see whether the IP is the cause after prior tests have been proven to not be the cause.
0
Challenges in Government Cyber Security

Has cyber security been a challenge in your government organization? Are you looking to improve your government's network security? Learn more about how to improve your government organization's security by viewing our on-demand webinar!

Laila JacksonAuthor Commented:
I have a feeling that it may be my powerline extender downstairs. I cannot seem to log into it directly because I cannot find its IP address.

Even with the TP Link utilities, I cannot locate it at all.

I am not so skilled in networking.

Below, I have enclosed IP address - Subnet Mask - Gateway for the NAS then IP's for everything else connected to my router:

Wired LAN
NAS Port 1 - 192.168.0.7 - 255.255. 255.0 - Nothing
NAS Port 2 - 192.168.0.2 - 255.255. 255.0 - 192.168.0.1

Laptop Downstairs - 192.168.0.10 -  255.255. 255.0 - 192.168.0.1  (connected via powerline adapter upstairs)
Win7 Home Desktop PC - 192.168.0.6 - 255.255. 255.0 - 192.168.0.1

2.4ghz Wireless LAN
192.168.0.4 - Windows 8 Phone
192.168.0.5 - iPhone

Are you accessing the NAS downstairs by IP or by name?

Not sure what you mean by this. I am connected to the network through an Ethernet cable which runs from my downstairs laptop to a powerline adapter downstairs. This adapter is then connected to its base upstairs. The base is connected to my router using an Ethernet cable to my router.
 
Lai
0
arnoldCommented:
When you want to access the NAS, what do you do? Are you going to network places?
If so, you do not see either the NAS nor any other system?
In this case, you need to check whether the your downstairs system is using the same name for the group to which it belongs.
I.e. The windows7 upstairs and the NAS is in the myworkgroup while your downstairs system is in the myhomegroup
Adjusting the laptop's properties of computer, advanced settings, computer name tab, changing the group to match that on the upstairs system in the example above from myhomegroup to myworkgroup. After reboot, you should see the upstairs computer and the NAS in my network places.
Are the two systems use the same windows 7 versions?  Home/pro/or ultimate?

Try the following on the downstairs system start key+R, it should open a Run command interface.  There try to use \\192.168.0.2 and see if you get prompted for credentials.

The AV500 does not have an interface to connect to.  To access your router is at 192.168.0.1
0
SnibborgOwnerCommented:
I think we need to look at the powerline a little more closely.  Are you plugging it directly into a wall socket or is it on a extension lead?  They don't like extensions.

Have you tried taking the downstairs laptop and Powerline upstairs and plugging them into the wall up there so they are on the same ring?  This will enable you to find out whether this is where it is plugged in or whether it is faulty.

Powerline devices can be a bit fussy over where they work.  Both adapters need to be on the same power circuit.  So if you have separate fuse boxes upstairs and downstairs they will often not work.
0
arnoldCommented:
Presumably, the downstairs system has Internet access which I believe eliminates the issue as being the power line interface.
If I am not mistaken, the powerline simply extends the network and does not have its own DHCP server. The downstairs system gets an IP.
0
profgeekCommented:
Try moving your laptop upstairs and connecting directly into your D6200 router.  If you can now see the NAS, then something is going on with the powerline adapters.  If you still can't see the NAS, then something is probably going on with your laptop configuration.  The key to troubleshooting this stuff is to eliminate variables.  Right now, you don't know if the problem is the laptop or the Powerline, so we need to eliminate one of them.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Laila JacksonAuthor Commented:
Great help sorry for the delay in closing.

This process of elimination worked well for me. I found that the issue was in fact my downstairs work  so I uninstalled and reinstalled all the networking drivers and it was working as expected within minutes.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Networking Hardware-Other

From novice to tech pro — start learning today.