facebook api error og:type

Hi, I have a probleme with many of my web pages using the facebook api, all of them have the same html code and all the needed meta-properties are there but for some of them there's nothing happening when asking to post comment on facebook.    All seems to be normal when you make the comment but the message just ends up nowhere on fb.

When I go to the object debugger, there's a message about the og:type missing but it is there in the raw tags that are displayed.   Also, I have this message : og:image could not be downloaded or is too small, I can't seem to find anything wrong with the image.   Lastly there's this message too : Parser Mismatched Metadata.

This page is working fine:
http://www.spaavic.com/default.asp?choix=3&IdPet=9704

This page is not:
http://www.spaavic.com/default.asp?choix=4&IdPet=9748

Same syntax for both, I just don't get it...
Buropro-CitationAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

F PCommented:
Yes, you're missing a few things....

<html xmlns="http://www.w3.org/1999/xhtml">
<head prefix="og: http://ogp.me/ns# object: http://ogp.me/ns/object#">

Open in new window


Make those changes and you should be golden.
0
F PCommented:
I usually put this first too:

<meta property="og:type" content="website" />

Open in new window


followed by og:title, but if it works...
0
Buropro-CitationAuthor Commented:
I have made the changes to the web page but I still have the same errors and all posts still don't show up in fb.    What is the next step I should make?
0
F PCommented:
No, it works. The problem was that you had to click the button called, "Fetch New Scrape Information" underneath the URL on the debugger once you actually came to the page with the error.

https://developers.facebook.com/tools/debug/og/object/
Screen-Shot-2015-04-25-at-5.34.08-PM.png
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Buropro-CitationAuthor Commented:
Ok, one problem solved :)   I thought that this was why my posts are not showing up in FB but there must be another reason.    When I post a comment, I'm telling to post it on FB, the comment is showing up in the spaavic web page but not in my personal fb wall and I can't seem to find why.   Sometimes it works but most of the time it's not, do you know why it is so?
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Facebook

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.