open port 993, 995, 110, 143 for mail server

Hi,

I'm trying to open up the ports for the mail server ports: 993, 995, 110, 143.

When I use:

sudo ufw status verbose
Status: active
Logging: on (low)
Default: deny (incoming), allow (outgoing), disabled (routed)
New profiles: skip

To                         Action      From
--                         ------      ----
22                         ALLOW IN    Anywhere
80                         ALLOW IN    Anywhere
443                        ALLOW IN    Anywhere
25                         ALLOW IN    Anywhere
587                        ALLOW IN    Anywhere
110                        ALLOW IN    Anywhere
995                        ALLOW IN    Anywhere
143                        ALLOW IN    Anywhere
993                        ALLOW IN    Anywhere
993/tcp                    ALLOW IN    Anywhere
22 (v6)                    ALLOW IN    Anywhere (v6)
80 (v6)                    ALLOW IN    Anywhere (v6)
443 (v6)                   ALLOW IN    Anywhere (v6)
25 (v6)                    ALLOW IN    Anywhere (v6)
587 (v6)                   ALLOW IN    Anywhere (v6)
110 (v6)                   ALLOW IN    Anywhere (v6)
995 (v6)                   ALLOW IN    Anywhere (v6)
143 (v6)                   ALLOW IN    Anywhere (v6)
993 (v6)                   ALLOW IN    Anywhere (v6)
993/tcp (v6)               ALLOW IN    Anywhere (v6)

Open in new window


when I use nmap --open though I get this:

Not shown: 991 closed ports
PORT      STATE SERVICE
22/tcp    open  ssh
25/tcp    open  smtp
80/tcp    open  http
443/tcp   open  https
587/tcp   open  submission
783/tcp   open  spamassassin
3306/tcp  open  mysql
5432/tcp  open  postgresql
10024/tcp open  unknown

Open in new window


I tried this:
sudo iptables -A INPUT -p tcp --dport 993 -j ACCEPT

and also this:
sudo ufw allow 993

but the nmap is still the same. I tried testing with telnet and openssl s_client -connect but the ports are, obviously, closed. What am I missing?

Much thanks and Father God bless<><,
Victor
Victor KimuraSEO, Web DeveloperAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Zephyr ICTCloud ArchitectCommented:
Did you try with:

sudo ufw allow imaps 

Open in new window

0
arnoldCommented:
Are you not able to connect to those ports?

OpenSSL s_client -connect <ipaddress>:993 and see what you get
Note none of the encrypted ports are reflected as open 993, 995.
You can repeat the same command with port 995 to confirm the pop3 is working.
To close session based on port:
993:a logout
995:quit
0
David359Commented:
Depending on the version of Linux, try:

firewall-cmd --zone=public --add-port=110/tcp --permanent
firewall-cmd --zone=public --add-port=143/tcp --permanent
firewall-cmd --zone=public --add-port=993/tcp --permanent
firewall-cmd --zone=public --add-port=995/tcp --permanent

This is what I used on CentOS 7
0
What were the top attacks of Q1 2018?

The Threat Lab team analyzes data from WatchGuard’s Firebox Feed, internal and partner threat intelligence, and a research honeynet, to provide insightful analysis about the top threats on the Internet. Check out our Q1 2018 report for smart, practical security advice today!

Victor KimuraSEO, Web DeveloperAuthor Commented:
@spravtek, no, unfortunately, that didn't work.

@arnold, this is what I get:

forge@myultratrust/etc/ufw $ openssl s_client -connect 104.131.13.87:993
connect: Connection refused
connect:errno=111

Open in new window


When I look in /etc/ufw with ls -al:
total 44
drwxr-xr-x   3 root root 4096 Apr 25 13:14 .
drwxr-xr-x 109 root root 4096 Apr 25 02:35 ..
-rw-r-----   1 root root  915 Feb 28  2014 after6.rules
-rw-r-----   1 root root 1126 Apr 17  2014 after.init
-rw-r-----   1 root root 1004 Feb 28  2014 after.rules
drwxr-xr-x   2 root root 4096 Apr 24 01:31 applications.d
-rw-r-----   1 root root 3225 Feb 28  2014 before6.rules
-rw-r-----   1 root root 1130 Apr 17  2014 before.init
-rw-r-----   1 root root 2667 Feb 28  2014 before.rules
-rw-r--r--   1 root root 1941 Feb 28  2014 sysctl.conf
-rw-r--r--   1 root root  313 Feb 14 22:02 ufw.conf

Open in new window


But not sure what I should be changing. I read these update the iptables. I also read the order of the rules are important but not sure how I go about it. I'm using Ubuntu 14.04.1 - fyi.

forge@myultratrust/etc/ufw $ cat /etc/issue
Ubuntu 14.04.1 LTS \n \l
0
Victor KimuraSEO, Web DeveloperAuthor Commented:
@David359,

I get this:

firewall-cmd --zone=public --add-port=993/tcp --permanent
The program 'firewall-cmd' is currently not installed. You can install it by typing:
sudo apt-get install firewalld

Open in new window


Wondering if I should install it? I think Ubuntu uses the UFW. Should I use that instead of the UFW command?
0
David359Commented:
Hi Vkimura2007,
I am not familiar with Ubuntu or UFW, but I would speculate that UFW is a front end for iptables just like firewall-cmd.  I believe firewall-cmd was default installed with CentOS 7 for the first time.  I believe I had to do something different in CentOS 6.

If you wanted to play around you could install firewalld using the command in your post above.  You may need to remove UFW so they don't fight each other in creating iptables scripts.  

To confirm iptables is what is preventing your connections you can temporarily stop iptables and verify that connectivity works.  Sorry  I don't know the  Ubuntu command to do that.  

You can look at the active iptables scripts with:
iptables-save
ip6tables-save

You can redirect the output to a file if it is too big for your screen.

David
0
Dave BaldwinFixer of ProblemsCommented:
On my Ubuntu machine, ports 110 and 143 are open on the machine IP address but Not on localhost.  I don't have the 'secure' ports enabled in the mail server.
0
Victor KimuraSEO, Web DeveloperAuthor Commented:
@David359, Ok thanks.

@Dave Baldwin, was that by default that the ports 110 and 143 were opened?

I ran the sudo iptables -L and got the following. It looks like the ports are opened but I can't telnet or nmap can't see it opened:

sudo iptables -L
Chain INPUT (policy DROP)
target     prot opt source               destination
fail2ban-ssh  tcp  --  anywhere             anywhere             multiport dports ssh
ufw-before-logging-input  all  --  anywhere             anywhere
ufw-before-input  all  --  anywhere             anywhere
ufw-after-input  all  --  anywhere             anywhere
ufw-after-logging-input  all  --  anywhere             anywhere
ufw-reject-input  all  --  anywhere             anywhere
ufw-track-input  all  --  anywhere             anywhere
ACCEPT     tcp  --  anywhere             anywhere             tcp dpt:imaps

Chain FORWARD (policy DROP)
target     prot opt source               destination
ufw-before-logging-forward  all  --  anywhere             anywhere
ufw-before-forward  all  --  anywhere             anywhere
ufw-after-forward  all  --  anywhere             anywhere
ufw-after-logging-forward  all  --  anywhere             anywhere
ufw-reject-forward  all  --  anywhere             anywhere
ufw-track-forward  all  --  anywhere             anywhere

Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination
ufw-before-logging-output  all  --  anywhere             anywhere
ufw-before-output  all  --  anywhere             anywhere
ufw-after-output  all  --  anywhere             anywhere
ufw-after-logging-output  all  --  anywhere             anywhere
ufw-reject-output  all  --  anywhere             anywhere
ufw-track-output  all  --  anywhere             anywhere

Chain fail2ban-ssh (1 references)
target     prot opt source               destination
RETURN     all  --  anywhere             anywhere

Chain ufw-after-forward (1 references)
target     prot opt source               destination

Chain ufw-after-input (1 references)
target     prot opt source               destination
ufw-skip-to-policy-input  udp  --  anywhere             anywhere             udp dpt:netbios-ns
ufw-skip-to-policy-input  udp  --  anywhere             anywhere             udp dpt:netbios-dgm
ufw-skip-to-policy-input  tcp  --  anywhere             anywhere             tcp dpt:netbios-ssn
ufw-skip-to-policy-input  tcp  --  anywhere             anywhere             tcp dpt:microsoft-ds
ufw-skip-to-policy-input  udp  --  anywhere             anywhere             udp dpt:bootps
ufw-skip-to-policy-input  udp  --  anywhere             anywhere             udp dpt:bootpc
ufw-skip-to-policy-input  all  --  anywhere             anywhere             ADDRTYPE match dst-type BROADCAST

Chain ufw-after-logging-forward (1 references)
target     prot opt source               destination
LOG        all  --  anywhere             anywhere             limit: avg 3/min burst 10 LOG level warning prefix "[UFW BLOCK] "

Chain ufw-after-logging-input (1 references)
target     prot opt source               destination
LOG        all  --  anywhere             anywhere             limit: avg 3/min burst 10 LOG level warning prefix "[UFW BLOCK] "

Chain ufw-after-logging-output (1 references)
target     prot opt source               destination

Chain ufw-after-output (1 references)
target     prot opt source               destination

Chain ufw-before-forward (1 references)
target     prot opt source               destination
ACCEPT     all  --  anywhere             anywhere             ctstate RELATED,ESTABLISHED
ACCEPT     icmp --  anywhere             anywhere             icmp destination-unreachable
ACCEPT     icmp --  anywhere             anywhere             icmp source-quench
ACCEPT     icmp --  anywhere             anywhere             icmp time-exceeded
ACCEPT     icmp --  anywhere             anywhere             icmp parameter-problem
ACCEPT     icmp --  anywhere             anywhere             icmp echo-request
ufw-user-forward  all  --  anywhere             anywhere

Chain ufw-before-input (1 references)
target     prot opt source               destination
ACCEPT     all  --  anywhere             anywhere
ACCEPT     all  --  anywhere             anywhere             ctstate RELATED,ESTABLISHED
ufw-logging-deny  all  --  anywhere             anywhere             ctstate INVALID
DROP       all  --  anywhere             anywhere             ctstate INVALID
ACCEPT     icmp --  anywhere             anywhere             icmp destination-unreachable
ACCEPT     icmp --  anywhere             anywhere             icmp source-quench
ACCEPT     icmp --  anywhere             anywhere             icmp time-exceeded
ACCEPT     icmp --  anywhere             anywhere             icmp parameter-problem
ACCEPT     icmp --  anywhere             anywhere             icmp echo-request
ACCEPT     udp  --  anywhere             anywhere             udp spt:bootps dpt:bootpc
ufw-not-local  all  --  anywhere             anywhere
ACCEPT     udp  --  anywhere             224.0.0.251          udp dpt:mdns
ACCEPT     udp  --  anywhere             239.255.255.250      udp dpt:1900
ufw-user-input  all  --  anywhere             anywhere

Chain ufw-before-logging-forward (1 references)
target     prot opt source               destination

Chain ufw-before-logging-input (1 references)
target     prot opt source               destination

Chain ufw-before-logging-output (1 references)
target     prot opt source               destination

Chain ufw-before-output (1 references)
target     prot opt source               destination
ACCEPT     all  --  anywhere             anywhere
ACCEPT     all  --  anywhere             anywhere             ctstate RELATED,ESTABLISHED
ufw-user-output  all  --  anywhere             anywhere

Chain ufw-logging-allow (0 references)
target     prot opt source               destination
LOG        all  --  anywhere             anywhere             limit: avg 3/min burst 10 LOG level warning prefix "[UFW ALLOW] "

Chain ufw-logging-deny (2 references)
target     prot opt source               destination
RETURN     all  --  anywhere             anywhere             ctstate INVALID limit: avg 3/min burst 10
LOG        all  --  anywhere             anywhere             limit: avg 3/min burst 10 LOG level warning prefix "[UFW BLOCK] "

Chain ufw-not-local (1 references)
target     prot opt source               destination
RETURN     all  --  anywhere             anywhere             ADDRTYPE match dst-type LOCAL
RETURN     all  --  anywhere             anywhere             ADDRTYPE match dst-type MULTICAST
RETURN     all  --  anywhere             anywhere             ADDRTYPE match dst-type BROADCAST
ufw-logging-deny  all  --  anywhere             anywhere             limit: avg 3/min burst 10
DROP       all  --  anywhere             anywhere

Chain ufw-reject-forward (1 references)
target     prot opt source               destination

Chain ufw-reject-input (1 references)
target     prot opt source               destination

Chain ufw-reject-output (1 references)
target     prot opt source               destination

Chain ufw-skip-to-policy-forward (0 references)
target     prot opt source               destination
DROP       all  --  anywhere             anywhere

Chain ufw-skip-to-policy-input (7 references)
target     prot opt source               destination
DROP       all  --  anywhere             anywhere

Chain ufw-skip-to-policy-output (0 references)
target     prot opt source               destination
ACCEPT     all  --  anywhere             anywhere

Chain ufw-track-forward (1 references)
target     prot opt source               destination

Chain ufw-track-input (1 references)
target     prot opt source               destination

Chain ufw-track-output (1 references)
target     prot opt source               destination
ACCEPT     tcp  --  anywhere             anywhere             ctstate NEW
ACCEPT     udp  --  anywhere             anywhere             ctstate NEW

Chain ufw-user-forward (1 references)
target     prot opt source               destination

Chain ufw-user-input (1 references)
target     prot opt source               destination
ACCEPT     tcp  --  anywhere             anywhere             tcp dpt:ssh
ACCEPT     udp  --  anywhere             anywhere             udp dpt:ssh
ACCEPT     tcp  --  anywhere             anywhere             tcp dpt:http
ACCEPT     udp  --  anywhere             anywhere             udp dpt:http
ACCEPT     tcp  --  anywhere             anywhere             tcp dpt:https
ACCEPT     udp  --  anywhere             anywhere             udp dpt:https
ACCEPT     tcp  --  anywhere             anywhere             tcp dpt:smtp
ACCEPT     udp  --  anywhere             anywhere             udp dpt:25
ACCEPT     tcp  --  anywhere             anywhere             tcp dpt:submission
ACCEPT     udp  --  anywhere             anywhere             udp dpt:submission
ACCEPT     tcp  --  anywhere             anywhere             tcp dpt:pop3
ACCEPT     udp  --  anywhere             anywhere             udp dpt:pop3
ACCEPT     tcp  --  anywhere             anywhere             tcp dpt:pop3s
ACCEPT     udp  --  anywhere             anywhere             udp dpt:pop3s
ACCEPT     tcp  --  anywhere             anywhere             tcp dpt:imap2
ACCEPT     udp  --  anywhere             anywhere             udp dpt:imap2
ACCEPT     tcp  --  anywhere             anywhere             tcp dpt:imaps
ACCEPT     udp  --  anywhere             anywhere             udp dpt:imaps
ACCEPT     tcp  --  anywhere             anywhere             tcp dpt:imaps

Chain ufw-user-limit (0 references)
target     prot opt source               destination
LOG        all  --  anywhere             anywhere             limit: avg 3/min burst 5 LOG level warning prefix "[UFW LIMIT BLOCK] "
REJECT     all  --  anywhere             anywhere             reject-with icmp-port-unreachable

Chain ufw-user-limit-accept (0 references)
target     prot opt source               destination
ACCEPT     all  --  anywhere             anywhere

Chain ufw-user-logging-forward (0 references)
target     prot opt source               destination

Chain ufw-user-logging-input (0 references)
target     prot opt source               destination

Chain ufw-user-logging-output (0 references)
target     prot opt source               destination

Chain ufw-user-output (1 references)
target     prot opt source               destination

Open in new window

0
arnoldCommented:
try the IP as <127.0.0.1>

The IP you used appears to be public (external) is that IP reflected in ifconfig -a
You need to use your LAN IP.

try openssl s_client -connect 127.0.0.1:993 This uses the external interface.
ifconfig will likely show you a 192.168.x.x ip addresss.  if you need external, you would need to configure your external firewall with port forwarding for each of the above to the internal 192.168.x.x of this system and the same port.
0
Dave BaldwinFixer of ProblemsCommented:
I don't know what you mean by default because I haven't seen any ports open 'by default' on my Ubuntu systems.  I fired up my second Ubuntu machine and it does show ports 110 and 143 open on 'localhost' as well as the machine IP.  I must have the two mail servers set up differently.  Or maybe the firewall.
0
Victor KimuraSEO, Web DeveloperAuthor Commented:
@arnold,

Ok. It seems that the connection is still refused on 127.0.0.1:

forge@myultratrust/var/log $ openssl s_client -connect 127.0.0.1:993
connect: Connection refused
connect:errno=111

Open in new window


I don't see a 192.168.x.x. in my ifconfig though:

 /sbin/ifconfig -a
eth0      Link encap:Ethernet  HWaddr 04:01:3f:67:2c:01
          inet addr:104.131.13.87  Bcast:104.131.63.255  Mask:255.255.192.0
          inet6 addr: fe80::601:3fff:fe67:2c01/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1503521 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1380023 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:890370056 (890.3 MB)  TX bytes:1320284280 (1.3 GB)

eth1      Link encap:Ethernet  HWaddr 04:01:3f:67:2c:02
          inet addr:10.132.97.202  Bcast:10.132.255.255  Mask:255.255.0.0
          inet6 addr: fe80::601:3fff:fe67:2c02/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:7 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:578 (578.0 B)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:434190 errors:0 dropped:0 overruns:0 frame:0
          TX packets:434190 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:376198994 (376.1 MB)  TX bytes:376198994 (376.1 MB)

Open in new window


What's the command for port forwarding to the internal IP and port? TY!
0
Victor KimuraSEO, Web DeveloperAuthor Commented:
@Dave Balwin, can you share what you have in your /etc/ufw files? They have all the settings for the firewall rules I think.
0
Dave BaldwinFixer of ProblemsCommented:
In /etc/ufw/applications.d in the dovecot-common file, I have this but I have not set up the mail server with a certificate to listen on ports 993 and 995 so they won't be 'open' on my system.  Ports are never open unless you have a program listening at that port.
[Dovecot POP3]
title=Secure mail server (POP3)
description=Dovecot is a mail server whose major goals are security and extreme
 reliability.
ports=110/tcp

[Dovecot Secure POP3]
title=Secure mail server (POP3S)
description=Dovecot is a mail server whose major goals are security and extreme
 reliability.
ports=995/tcp

[Dovecot IMAP]
title=Secure mail server (IMAP)
description=Dovecot is a mail server whose major goals are security and extreme
 reliability.
ports=143/tcp

[Dovecot Secure IMAP]
title=Secure mail server (IMAPS)
description=Dovecot is a mail server whose major goals are security and extreme
 reliability.
ports=993/tcp

Open in new window

0
arnoldCommented:
Is this the system where the mail is or are you using this system as a router.

The LAN IP is 10.132.97.202

There are different configurations on a system that has two NICs one public and one LAN.

You need to check which rules and to which interface they apply.
0
Victor KimuraSEO, Web DeveloperAuthor Commented:
@Dave Balwin, ok, thanks!

I have this

sudo ufw app list
Available applications:
  Dovecot IMAP
  Dovecot POP3
  Dovecot Secure IMAP
  Dovecot Secure POP3
  Nginx Full
  Nginx HTTP
  Nginx HTTPS
  OpenSSH
  Postfix
  Postfix SMTPS
  Postfix Submission

Open in new window


But the Postfix SMPTS is using 25:

sudo ufw app info Postfix SMTPS
Profile: Postfix
Title: Mail server (SMTP)
Description: Postfix is a high-performance mail transport agent

Port:
  25/tcp

Open in new window


And when I try this:

sudo ufw app info Dovecot Secure IMAP
ERROR: Could not find profile 'Dovecot'

Open in new window


I have what you have /etc/ufw/applications.d in the dovecot-common file too. Not sure why sudo ufw app info cannot find the Dovecot profile.

I have this in my /etc/ufw/applications.d/postfix

forge@myultratrust/etc/ufw/applications.d $ sudo vim postfix
[Postfix]
title=Mail server (SMTP)
description=Postfix is a high-performance mail transport agent
ports=25/tcp

[Postfix SMTPS]
title=Mail server (SMTPS)
description=Postfix is a high-performance mail transport agent
ports=465/tcp

[Postfix Submission]
title=Mail server (Submission)
description=Postfix is a high-performance mail transport agent
ports=587/tcp
~

Open in new window


@arnold,
I'm not sure if the system is a router. I'm using Digital Ocean for my Cloud server. I think they are similar to Linode.

How do I check which rules to which interface they apply? Or I guess how would I change them to apply to the correct IP?
0
Victor KimuraSEO, Web DeveloperAuthor Commented:
I tried disable the ufw and using telnet but the connection was still refused:


forge@myultratrust/etc/ufw/applications.d $ sudo ufw disable
Firewall stopped and disabled on system startup
forge@myultratrust/etc/ufw/applications.d $ telnet livingtrustdiy.com 993
Trying 104.131.13.87...
telnet: Unable to connect to remote host: Connection refused
forge@myultratrust/etc/ufw/applications.d $ sudo ufw enable
Command may disrupt existing ssh connections. Proceed with operation (y|n)? y
Firewall is active and enabled on system startup
forge@myultratrust/etc/ufw/applications.d $ telnet livingtrustdiy.com 993
Trying 104.131.13.87...
telnet: Unable to connect to remote host: Connection refused
0
Dave BaldwinFixer of ProblemsCommented:
Maybe because telnet is not capable of making a secure connection to anything.  It does not support SSL/TLS.
0
arnoldCommented:
At this time, forget the name based usage.  Try using the 10.132.97.202 as the destination for 993, 995
in the openssl s_client -connect 10.132.97.202:993
openssl s_client -connect 10.132.97.202:995

telnet should have established the connection if the port is open, you will not see a response because SSL negotiation is needed.

iptables -t filter -L --line-numbers
iptables -t nat -L --line-numbers
0
Victor KimuraSEO, Web DeveloperAuthor Commented:
@arnold,

I found out through a lot of testing and just previewing the var/log/mail.log file

I was reading through this tutorial:
https://www.digitalocean.com/community/tutorials/how-to-configure-a-mail-server-using-postfix-dovecot-mysql-and-spamassasin

But the instructions state, in the file, /etc/dovecot/conf.d/10-master.conf to use:

##Uncomment inet_listener_imap and modify to port 0
service imap-login {
  inet_listener imap {
    port = 0
  }
}

Open in new window


But I commented the port line. I was reading this page on Ubuntu too:
https://help.ubuntu.com/community/PostfixBasicSetupHowto

though the instructions are for Courier and I set mine with Dovecot.

Other helpful references may be:
https://help.ubuntu.com/lts/serverguide/postfix.html
https://help.ubuntu.com/community/Dovecot
https://help.ubuntu.com/community/PostfixDovecotSASL
https://help.ubuntu.com/community/PostfixVirtualMailBoxClamSmtpHowto

I think the ubuntu site has quite a bit of tutorials though there are some changes as some of them are for older tutorials but the changes are not major in terms of configuration. Just use the search for dovecot and/or postfix. They were quite useful. I had to read the official docs too. I'll post my own server's configuration when I have time. I hope this will be helpful to others.

The problem was not so much of a port not being opened but a configuration problem. Thanks for your help.

Father God bless<><
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Victor KimuraSEO, Web DeveloperAuthor Commented:
I provided my answer but wanted to give points to those that helped as their answers made me search for the things that I needed to search for. :)
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Security

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.