numeric parameter - bigint,

I have a crystal report for visual studio 2010 edition. My report has a numeric parameter , the SQL serever field is bigint, the numbers length is 19. when I use the selection formula param=field I dont get the records filtered as expected.
HagitaAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

vastoCommented:
Did you verify the database ?
mlmccCommented:
How are you running the report?

How are you passing the parameter?

mlmcc
HagitaAuthor Commented:
The report is in desin,  I pass the value in report preview. later on will be called from c# .net
HTML5 and CSS3 Fundamentals

Build a website from the ground up by first learning the fundamentals of HTML5 and CSS3, the two popular programming languages used to present content online. HTML deals with fonts, colors, graphics, and hyperlinks, while CSS describes how HTML elements are to be displayed.

HagitaAuthor Commented:
when entering  long value like 1000000000000000123 the report wont bring any record. however if I send a shorter numeric value 100125 it filters the records fine
vastoCommented:
Use SQL Profiler and check what the report is actually sending to the SQL Server
mlmccCommented:
WHat data type does Crystal think the field is?

mlmcc
James0628Commented:
I think you may be running into a problem with how CR handles really large numbers.  CR 10 starts to have problems displaying values when they get up around 16 digits.  My guess is that you're running into a similar problem.  You could try making the parameter a string, and then either converting the string parameter to a number (which may just give you the same problem if done in CR), or maybe convert the bigint field to a string.

 James

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
HagitaAuthor Commented:
Thank you all experts. I think changing the field data type in the data base or conversion to string would be best. seems like CR cant handle big int values.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Crystal Reports

From novice to tech pro — start learning today.