Expire Certificates in personal store

Anyone know what this cert if for and how i could renew it. When I right click renew I get the error no cert template info. Dell AppAssure support is blaming it for causing backups to hang and fail. Windows Server 2008 64Bit. See attached screenshot.

Thanks
pitboyAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

pitboyAuthor Commented:
Craig BeckCommented:
It looks like the cert was issued to a CA running on that server (probably a subordinate).  I wouldn't delete it.
pitboyAuthor Commented:
had no plans to delete. looking to renew.
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

pitboyAuthor Commented:
server is used for file and print sharing only. Nothing else running.
Craig BeckCommented:
Fine to renew.
pitboyAuthor Commented:
craig, did you read my question?
Craig BeckCommented:
Sure did.

You said that you tried to renew it and it failed, and that Dell blamed it for a backup not working.

That tells me you're looking to delete the cert, based on Dell's info.
pitboyAuthor Commented:
"Anyone know what this cert if for and how i could renew it"

Dell is blaming the fact that it's expired for the backups failing. They are not telling me to delete.
Craig BeckCommented:
I'll say it again.  The cert was issued to a subordinate CA.

The cert expired nearly 12 months ago.  Has the backup not worked for that long?
pitboyAuthor Commented:
Guess I'm not understanding.

Says it was issued to (TLBSERVER5) by (TLBSERVER5) that's the machine with the problem. The only CA on the local network that I'm aware of is the DC. I looked on the DC and could not find this cert as being issued by it. What makes you think it was a subordinate CA? Is it not possible to renew if the subordinate is no longer available?

Backups have been fine until two weeks ago.
Craig BeckCommented:
The cert was issued by a CA called TLBSERVER5 - ROOT (that's not the CA server's name, but the CA name, if you get me?).

The cert you are trying to renew is a CA certificate, but it was issued by a different CA so it must be a subordinate CA itself.  If the subordinate doesn't exist anymore (ie, the role was removed) then you can't renew the cert because it's not a CA anymore.

Anyhow, Dell have got you chasing your tail.  If the cert expired nearly 12 months ago and the issue only began 2 weeks ago, it's not the cert that's to blame.

AppAssure uses a self-signed certificate by default, so looking at your certificates there isn't a self-signed cert there for AppAssure to use.  I'd say you need to generate a new cert, either by generating a self-signed cert on the server or by purchasing a 3rd-party cert...

https://support.software.dell.com/appassure/kb/117531

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
pitboyAuthor Commented:
Got it.

This server has only been used for file/print sharing since we bought it. I've never added or removed any roles. No clues as to how it could have had the CA role installed. I did convert it from Physical to VM but that was a couple years ago.

I figured as much with Dell.  I'm looking for a way to tell them they are full of it.

Thanks for the input.
pitboyAuthor Commented:
I found this.  It looks like it was from Symantec Backup Exec. Which we no longer use. Guessing it's safe to delete? See attached.
pitboyAuthor Commented:
Craig BeckCommented:
Yes you can delete that cert - it's expired.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2008

From novice to tech pro — start learning today.