• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2895
  • Last Modified:

detach all working copies and reset all version history in Xcode 6.3

0
down vote
favorite
      

I have been working on an Xcode project (that is installed via adhoc installation, for internal use at my company) for a few years now and I had enabled source control since day 1. All was working perfectly until when iOS 8 was released, i decided to convert it into iOS 8 while leaving a backup on the project as it is. So, I renamed the original folder to bimpad_old and started modifying the new project. I am a beginner in git, and I didn't know that doing this might corrupt source control. After doing so (and while still working on both projects) my source control won't commit anymore complaing that the project is not under version control.

I tried many solutions on the internet that suggest deleting .svn/.git folders, disabling and reenabling source control, run git init, add *, commit.. I also tried deleting the bimPad.xccheckout

I just want to lose all version history, detach/delete all working copies, and start new version control starting today.

How can I achieve that?

Notes:

    -At first, Xcode gave me a warning that svn needs to be updated.. I did it but still it wouldn't commit
    -I don't need online git (just local)
    -I stopped working on the old project.. and I don't need it anymore.
    -After all my tests and trials, it currently shows 3 working copies in my source control (when I enable it) and I only want one working copy (screenshot1 below)
screenshot1    -At earlier stages, when I was trying to commit, xcode was giving me a warning that it's unable to commit to www.mydomain.com/bimpad (a custom svn that a friend had made on his site a long time ago) but i can't find this reference anywhere.. (because i have deleted all repositories)
    -Now when I try to commit, i get the following error: the working copy "bimpad.xcodeproject" failed to commit files (screenshot2 below)
screenshot2
0
Dany Balian
Asked:
Dany Balian
1 Solution
 
Dany BalianCTOAuthor Commented:
Ok after days of trials and fixes, here's the fix to my problem.

1. disable source control from Xcode

2. Delete all .git/.svn folders from project folder

3. Clean Out the xccheckout file


1. Right Click on myproject.xcodeproj file and click show package contents
2. Righ Click on the xcworkspace file and click show package contents
3. go to xcshareddatafolder and edit the xccheckout file with your favourite editor
4. remove and references to any git servers that you don't need anymore

4. Remove Your Project from xcode projects

open XCode > Window > Projects and delete your project from the list

5. open finder to your project folder and re-initialize git by using the following commands

1. git init
2. git add .
3. git commit -m "Initial Commit"

6. Go to Xcode Preferences and Enable Source Control

7. Open Your Project, and Source Control is all cleaned up!

0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: Microsoft Windows 7 Basic

This introductory course to Windows 7 environment will teach you about working with the Windows operating system. You will learn about basic functions including start menu; the desktop; managing files, folders, and libraries.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now