• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 479
  • Last Modified:

Linux : third party GUI software to see health check of the server

Linux OS :

Can  you please advice any third party GUI software to see health system of Linux based servers.
where we can track all details on single-Click.

advice paid & free .. Both
0
mac_g
Asked:
mac_g
  • 9
  • 8
2 Solutions
 
woolmilkporcCommented:
I think you should try monitorix.

It's a web-based system data collection and monitoring tool.
The whole thing is written in Perl and uses an RRD database for storing historical data.

Here is the home page:
http://www.monitorix.org/

Depending on your Linux implementation you can install it just with

yum install monitorix
or
apt-get install monitorix
etc.

I urgently recommend using the above tools for installation, because there are quite a few dependencies to observe.

Once installed start the tool with

monitorx -c /etc/monitorix/monitorix.conf

Now point your browser to "http://hostname:8080/monitorix" and you'll see quite a lot of information in a graphical representation. A list of features is here:
http://www.monitorix.org/features.html

You can choose between daily, weekly, monthly and yearly reports.
Choosing the latter only makes sense once the tool has run a sufficient amount of time :-)

If your browser runs on the same system as monitorix itself you can of course use "localhost" instead of hostname.
0
 
mac_gAdmin - Oracle Fusion Middleware suiteAuthor Commented:
please can send me download link for this pkg and install steps.
I will have a try
0
 
woolmilkporcCommented:
Did you try "yum install monitorix" or "apt-get install monitorix?" as suggested above?

Manually installing just the monitorix package alone is not sufficient because of the many dependencies.

Anyway, the download link is here:

http://www.monitorix.org/downloads.html

and here are the instructions:

http://www.monitorix.org/installation.html

On the left click your particular Linux flavor!
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
mac_gAdmin - Oracle Fusion Middleware suiteAuthor Commented:
from below site link

http://www.monitorix.org/doc-redhat.html

I Did perform below steps

Install first the required packages.
# yum install rrdtool rrdtool-perl perl-libwww-perl perl-MailTools perl-MIME-Lite perl-CGI perl-DBI
perl-XML-Simple perl-Config-General perl-HTTP-Server-Simple perl-IO-Socket-SSL



I got the below output
---------------
Total                                                                                                                                                    3.2 MB/s | 1.1 MB     00:00
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
Warning: RPMDB altered outside of yum.
  Installing : perl-Net-SSLeay-1.35-9.el6.x86_64                                                                                                                                     1/8
  Installing : 1:perl-TimeDate-1.16-11.1.el6.noarch                                                                                                                                  2/8
  Installing : dejavu-lgc-sans-mono-fonts-2.30-2.el6.noarch                                                                                                                          3/8
  Installing : perl-Net-LibIDN-0.12-3.el6.x86_64                                                                                                                                     4/8
  Installing : perl-IO-Socket-SSL-1.31-2.el6.noarch                                                                                                                                  5/8
  Installing : rrdtool-1.3.8-6.el6.x86_64                                                                                                                                            6/8
  Installing : perl-MailTools-2.04-4.el6.noarch                                                                                                                                      7/8
  Installing : perl-Config-General-2.52-1.el6.noarch                                                                                                                                 8/8
  Verifying  : perl-Config-General-2.52-1.el6.noarch                                                                                                                                 1/8
  Verifying  : perl-Net-LibIDN-0.12-3.el6.x86_64                                                                                                                                     2/8
  Verifying  : perl-IO-Socket-SSL-1.31-2.el6.noarch                                                                                                                                  3/8
  Verifying  : dejavu-lgc-sans-mono-fonts-2.30-2.el6.noarch                                                                                                                          4/8
  Verifying  : 1:perl-TimeDate-1.16-11.1.el6.noarch                                                                                                                                  5/8
  Verifying  : rrdtool-1.3.8-6.el6.x86_64                                                                                                                                            6/8
  Verifying  : perl-MailTools-2.04-4.el6.noarch                                                                                                                                      7/8
  Verifying  : perl-Net-SSLeay-1.35-9.el6.x86_64                                                                                                                                     8/8

Installed:
  perl-Config-General.noarch 0:2.52-1.el6           perl-IO-Socket-SSL.noarch 0:1.31-2.el6           perl-MailTools.noarch 0:2.04-4.el6           rrdtool.x86_64 0:1.3.8-6.el6

Dependency Installed:
  dejavu-lgc-sans-mono-fonts.noarch 0:2.30-2.el6        perl-Net-LibIDN.x86_64 0:0.12-3.el6        perl-Net-SSLeay.x86_64 0:1.35-9.el6        perl-TimeDate.noarch 1:1.16-11.1.el6

Complete!
[root@RD-BPMDEV01 ~]# service monitorix start
monitorix: unrecognized service
[root@RD-BPMDEV01 ~]# rpm -ivh http://www.monitorix.org/monitorix-n.n.n-1.noarch.rpm
Retrieving http://www.monitorix.org/monitorix-n.n.n-1.noarch.rpm
curl: (22) The requested URL returned error: 404 Not Found
error: skipping http://www.monitorix.org/monitorix-n.n.n-1.noarch.rpm - transfer failed
[root@RD-BPMDEV01 ~]#
--------------

please advice further
0
 
woolmilkporcCommented:
You only installed the dependencies, but not the package itself!
0
 
mac_gAdmin - Oracle Fusion Middleware suiteAuthor Commented:
guide me next steps .. please
0
 
woolmilkporcCommented:
You missed the step "Download and install the Monitorix package" on the RedHat installation page: http://www.monitorix.org/doc-redhat.html
0
 
rindiCommented:
Check with your server hardware manufacturers. HP, Dell etc. have their own tools, and many also have hardware built-in (like HP's ILO and Dell's iDRAC) which you setup with their own IP and to which you can then connect via a browser and check the server's status, as well as having remote access to BIOS settings, boot console etc.
0
 
mac_gAdmin - Oracle Fusion Middleware suiteAuthor Commented:
[root@RD-BPMDEV01 ~]# rpm -ivh http://pkgs.repoforge.org/monitorix/monitorix-2.5.2-1.rf.src.rpm
Retrieving http://pkgs.repoforge.org/monitorix/monitorix-2.5.2-1.rf.src.rpm
warning: /var/tmp/rpm-tmp.4SpSkC: Header V3 DSA/SHA1 Signature, key ID 6b8d79e6: NOKEY
   1:monitorix              warning: user dag does not exist - using root 96%)
warning: group dag does not exist - using root
########################################### [100%]
[root@RD-BPMDEV01 ~]# service monitorix start
monitorix: unrecognized service

============
please adivice further
0
 
woolmilkporcCommented:
Try from command line

monitorix -c /etc/monitorix/monitorix.conf

then point your browser to port 8080 on the respective host.

If this works we can try to create a service later, yet I don't know why it shouldn't have been configured during installation.
0
 
mac_gAdmin - Oracle Fusion Middleware suiteAuthor Commented:
[root@RD-BPMDEV01 etc]# monitorix -c /etc/monitorix/monitorix.conf
-bash: monitorix: command not found
[root@RDOV-BPMDEV01 etc]# ls /etc/monitorix/monitorix.conf
ls: cannot access /etc/monitorix/monitorix.conf: No such file or directory
[root@RD-BPMDEV01 etc]#
0
 
woolmilkporcCommented:
You installed the source code of monitorix, not the binaries. Sorry, didn't see that before.

This is the wrong package:  monitorix-2.5.2-1.rf.src.rpm

You should have installed:  monitorix-2.5.2-1.el6.rf.noarch.rpm

Doesn't "yum install monitorix" work for you?
0
 
mac_gAdmin - Oracle Fusion Middleware suiteAuthor Commented:
i tried as adviced, below is output
-------------
[root@RD-BPMDEV01 etc]# rpm -ivh http://pkgs.repoforge.org/monitorix/monitorix-2.5.2-1.el6.rf.noarch.rpm
Retrieving http://pkgs.repoforge.org/monitorix/monitorix-2.5.2-1.el6.rf.noarch.rpm
warning: /var/tmp/rpm-tmp.4jp6nT: Header V3 DSA/SHA1 Signature, key ID 6b8d79e6: NOKEY
error: Failed dependencies:
        perl(MIME::Lite) is needed by monitorix-2.5.2-1.el6.rf.noarch
        perl(RRDs) is needed by monitorix-2.5.2-1.el6.rf.noarch
        perl-MIME-Lite is needed by monitorix-2.5.2-1.el6.rf.noarch
[root@RD-BPMDEV01 etc]#
0
 
woolmilkporcCommented:
You missed three dependencies which you'll have to install.

But again: Why don't you try "yum install monitorix" ??
0
 
mac_gAdmin - Oracle Fusion Middleware suiteAuthor Commented:
[root@RD-BPMDEV01 etc]# yum install monitorix
Loaded plugins: refresh-packagekit, security
local                                                                                                                                                             | 2.9 kB     00:00
Setting up Install Process
No package monitorix available.
Error: Nothing to do
[root@RD-BPMDEV01 etc]#
0
 
woolmilkporcCommented:
Well, it works on my Fedora systems but obviously not on RHEL.

So get the missing packages from here and install them manually using "rpm":

http://pkgs.repoforge.org/perl-MIME-Lite/perl-MIME-Lite-3.029-1.el6.rfx.noarch.rpm
http://pkgs.repoforge.org/perl-RRD-Simple/perl-RRD-Simple-1.44-1.el6.rf.noarch.rpm

If perl(MIME::Lite) is still missing after installing the above (which I doubt) get it from here:
https://cpan.metacpan.org/authors/id/R/RJ/RJBS/MIME-Lite-3.030.tar.gz
unpack it and install it with "perl Makefile.PL; make; make test; make install"
0
 
mac_gAdmin - Oracle Fusion Middleware suiteAuthor Commented:
failed again after followed above steps.

leave all about this tool.

this too looks messy ..am not happy such narrow installation which itself takes so much of heck

please advice some other better tool.
0
 
woolmilkporcCommented:
Good luck!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

On-Demand: Securing Your Wi-Fi for Summer Travel

Traveling this summer?Check out our on-demand webinar to learn about the importance of Wi-Fi security and 3 easy measures you can start taking immediately to protect your private data while using public Wi-Fi. Follow us today to learn more!

  • 9
  • 8
Tackle projects and never again get stuck behind a technical roadblock.
Join Now