Active Directory: cannot transfer Schema Master role

I'm working with Active Directory in what was a single-server 2008 R2 environment.  I've added a 2012 R2 DC, and everything was fine up to that point.  Now I want to demote the old 2008 R2 DC.  DCPromo failed because one of the FSMO roles couldn't be transferred to the new server.  So I used ntdsutil to transfer the roles manually.  All of the roles except the Schema Master transferred over with no problems, but when I try to transfer the Schema Master role it complains that it can't contact the existing server.  If I do a "netdom query fsmo", it reports the correct name of the old server as the Schema Master.

I've checked DNS settings on both servers, and they're both pointing to themselves as DNS server.  The old server does have 2 NICs, but the second one is disabled.

I'd really like to transfer the role "properly" rather than seizing the role.  What else can I look at, please?
LVL 1
wakatashiAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

vmaganCommented:
When you go into the schema MMC, did you connect to the target domain controller or is that where you are getting the error message?

Also, are you a member of the schema admins group? It will not work without you being a member of that group.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
wakatashiAuthor Commented:
Oh, that's just bizarre!  I checked that I was a member of Schema Admins (I'm using the built-in Administrator account, which was indeed a member).  Then I went to the Schema MMC and did it again with a view to getting a word-for-word error message out of it, and this time it worked!  I didn't do anything differently - I tried it several times before and then tried with ntdsutil because I couldn't get that to work.

Anyway, the main thing is the the old server is now happily DCPromo-ing itself out of being a Domain Controller, and all is right with the world.  Thanks very much for getting back to me!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Active Directory

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.