Windows 7 computer in reboot lock

I have several Windows 7 computers in reboot lock. Accourding to this it was Microsoft's doing

I have not found a solution for this. Anyone else? Please help.
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Codrut TambuSr. Software Developer EngineerCommented:
With Startup Repair selected, Windows will attempt to automate the repair; this might work – otherwise, further action will be required.
When Restore options fails, the infinite loop can be solved from the recovery console by manually recover the older registry.

Here's an detailed guide for this action:

Hope this helps,
GerhardpetAuthor Commented:
My problem is that I'm not onsite and trying to find a solution that I can apply remotely.
Codrut TambuSr. Software Developer EngineerCommented:
You should have mentioned that from start - the fact you have them on remote changed the question / situation.
You have more limited options by remote.
Do you still have access to those machines from your remote management console - or the infinite loop is something you guess or a person on site have reported to you?
Please provide more details so that the solution to be applied to your case.

Anyway, a point of start would be creating a template to run the Recovery Console by using a Remote Installation Service server

For details check this and adapt to your installation (about which you gave no details yet):
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

GerhardpetAuthor Commented:
From reading up on this I should have said that the computer is in a reboot look. The computer reboots with no problems but as soon as it is up the windows update reboot prompt pop up. I can dismiss it every time for 4 hours but not matter what I have tried it keeps on coming up.

I have already reset Windows updates and still the same problems.
Codrut TambuSr. Software Developer EngineerCommented:
Does this prompt occur with reason, after an real update? Or does it behave like a bug?

If it's after a certain update that does not manage to properly install (check error logs), either ignore that certain update, either solve the issue that block the installation and after properly install it, the popup will not bother you again.

If it's a bug-like
reason of the restart popup, use GPE/GPO to disable service or auto postone for 24H following this path:

If no GPE, you can also go for a registry change, like:

Open in new window

Change KEY: "NoAutoRebootWithLoggedOnUsers" (DWord) value to the required number.
0 = False (Allow auto-reboot)
1 = True (Disallow auto-reboot)
GerhardpetAuthor Commented:
It totally behaves like a bug. As soon as the computer comes up and I log in the reboot prompt screen pops up. I can dismiss it for up to 4 hours.

If I would use the registry to set it to 1 = True (Disallow auto-reboot) would it then ever again notify me if a legitimate reboot was required?

Whatever I do I still want the windows update to remain fully functional.
Codrut TambuSr. Software Developer EngineerCommented:
The notification occurs, but not the restart while a user is logged in.
Mainly you will be notified about the restart when you log-out or shut-down machine.
GerhardpetAuthor Commented:
The regedit did not solve the problem. Computer is still in reboot lock.
Codrut TambuSr. Software Developer EngineerCommented:
What about GPE/GPO, have you tried the Windows Computer Policy, as I've mentioned in the earlier posts?

Follow this link, and try setting to enabled and the minutes delay to 1440 (24h):

Start / Run / gpedit.msc 
GO TO:>/ Local Computer Policy / Computer Configuration / Administrative Templates / Windows Components / Windows Update / Re-prompt for restart with scheduled installations

Open in new window

Specifies the amount of time for Automatic Updates to wait before prompting again with a scheduled restart.

If the status is set to Enabled, a scheduled restart will occur the specified number of minutes after the previous prompt for restart was postponed.

If the status is set to Disabled or Not Configured, the default interval is 10 minutes.

Note: This policy applies only when Automatic Updates is configured to perform scheduled installations of updates. If the "Configure Automatic Updates" policy is disabled, this policy has no effect.
GerhardpetAuthor Commented:

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
GerhardpetAuthor Commented:
Check the link in the accepted solution
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 7

From novice to tech pro — start learning today.