Nexus 9396

try to get an sfp mpls fiber circuit up at our colo.  In the past  i've used the command 'no negotiate auto' on the interface on the 5k series.   but i don't see this as an option on the 9K?
techlindenAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Don JohnstonInstructorCommented:
Which port and which SFP?

And you're not trying to do MPLS on the 9300, right? Because the 9k's can't do MPLS.
0
techlindenAuthor Commented:
It's a glc-lh-smd sfp.  we're not trying to do mpls on the nexus.  It's mpls on the provider backbone i believe.  Essentially, it's a layer 3 single mode fiber handoff from at&t.  It's an avpn circuit.  We have the exact same circuit at another datacenter going into a 5k and i had to  issue the command no negotiate auto before the link would come up.   speed and duplex are already hard-coded.
0
Don JohnstonInstructorCommented:
It could be that the command is not available because that SFP is 1g only.  The command itself is valid on the 9300's.
0
techlindenAuthor Commented:
I opened a ticket with Cisco.   there was a bug in our nx-os.   You need to put the command 'no negotiate auto' on the interface and that command isn't available in the version we were on.  - 6.1(2)I3(3a)

we upgraded to  6.1(2)I3(4) and the problem is fixed.  we now  have our avpn circuit up after being able to issue that command.  One word of caution from the cisco tech was that was a recently found bug in  6.1(2)I3(4) that can cause the system to crash if you try to statically set the mtu on a vlan interface which i don't think we have the need to do.  

Anyway, issue solved.  Thanks
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
techlindenAuthor Commented:
issue is fixed.    Thanks
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Routers

From novice to tech pro — start learning today.