cannot see terminal screen while a remote desktop user is logged in

Hi Experts

our setup is a server 2012r2 running business apps, a terminal server 2008r2 for remote users

The apps must be run on the 2012 server while a session (RDP or from the console) is active. my problem is that if i reboot the server remotely at night using RDP , I log back in and start up the app and close the session (not log off). Now if someone needs to go to the servers terminal in the rack and tries to log on, they get a grey screen with no ability to log on or see even the cntrl +alt+ del screen.  the mouse wakes the screen up but its just grey.
Ive tried taking out the KVM and tried logging on as /admin to no avail. im a bit stuck :(

any thoughts?

James
uEAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Leon KammerCommented:
Hi,

The user needs to log in to be able to interact with the desktop locally.
When you log into the machine Remotely, your session is still alive if you exit without logging out, but until logging into the machine locally, nobody will be able to see your session.
If they log in as you, they will see the desktop as you left it.

hth

Leon
0
matrix8086Commented:
You have to add the role of Remote Desktop Services to the server. Without that role enabled, the server will permit only one connection at one time. So if you are logged in through RDP you will not be abble to connect from terminal and viceversa
0
uEAuthor Commented:
thanks matrix, Ill check the remote desktop services permission, Leon we used to be able to just take over the session locally  after RDP session.
0
10 Tips to Protect Your Business from Ransomware

Did you know that ransomware is the most widespread, destructive malware in the world today? It accounts for 39% of all security breaches, with ransomware gangsters projected to make $11.5B in profits from online extortion by 2019.

uEAuthor Commented:
Matrix, we have the other server 2008 doing our RDS I dont want to enable RDS on this server too seing as I dont want to log into the 2012 AD server multiple times I just want to take over the session locally. so far we cannot and get just a grey screen.
0
Leon KammerCommented:
Just to clarify.
Are you logging into the machine using the same credentials you use to sign in through RDP?

If not, the user will not see the same session.
If you have an active RDP session, and somebody logs in using your credentials, locally, your session is closed down.
They will see your session.

Cheers

Leon
0
matrix8086Commented:
As I can figure, you have not enabled the Remote Desktop in the Windows 2012 Server. To check that, open Server Manager -> Local Server and see in the right if Remote Desktop is Disabled or Enabled.

Or you can go in Control Panel -> System, the rightest tab is Remote which one it interest you.

Best regards!
0
Leon KammerCommented:
Hi uE

Is this an AD server??
Remote Desktop Services cannot co-exist with AD Services.
Go in through the MMC - ADUC and check the terminal Services protocols.
If you're not using AD logins (local login) when you RDP in, go in through MMC - Local Computer Policy and check the RD Session Connection protocols.

Cheers

Leon
0
uEAuthor Commented:
Leon, we are trying to use the same credentials through RDP and locally. thats exactly whats not happening.
This is setup as the AD and we are using another server with remote desktop services.
Matrix, RDP is enabled.
0
uEAuthor Commented:
sorry for the gap in responding, got busy with another client.
0
uEAuthor Commented:
Still happening, have tried changing screens on the terminal , turned off requirement for NLA on RDP, nothing seems to work.
anyone?
0
Leon KammerCommented:
This may be an incompatibility issue with the Screen resolution between the local session and the RDP session..
Try setting the Screen Resolution to something smaller within your RDP session.
(Answer from MS Support).
I am a little dubious, but could have something to do with the removal of Shadowing.

Cheers

Leon
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
uEAuthor Commented:
It's not a great monitor by any stretch. I'll give this a go on Wednesday when I'm out there next.
Cheers
0
uEAuthor Commented:
Thanks Leon

It was likely the resolution that the RDP session was starting at then when the local session tried to connect the RDP session resolution was too high for the screen. I would have thought it would resize the resolution when a new session would connect, Is there a setting for this?

anyway thanks for all responses guys

cheers

James
0
Leon KammerCommented:
Hi James,

You are welcome.
I am not 100% certain, I know there was a setting in Administrative shadowing to resize the desktop screen resolution, but since this has been removed I am not sure where to begin...

Cheers

Leon
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Server OS

From novice to tech pro — start learning today.