Exchange 2013 Replication

We have 2 Exchange 2013 servers on Windows 2012 R2.  One in our corporate office and one in another city.   The witness server is in our corporate office (Consulting group put it here and never told us about it until we lost both servers, I am trying to get it moved).  However, I continue to get warning messages Event ID 4123  "Failed to get the boot time of witness server 'witness.domain.com'. Error: Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED))  These show up a few times a day.

I ran  Test-replicationhealth, everything passed except QuorumGroup.  this failed with "Quorum resource 'Cluster Group' is not online on server 'exchangedr'. Database availability group 'DAG' might not be reachable or may have lost redundancy. Error: ..."

Any ideas what could be causing this?  We also cannot reboot either server without having failed contentindexstate after the reboot.  We were told this is normal and it will go away, and it will after about 4 days.  Makes doing maintenance a real pain.  Let me know if you need more information.  

Thanks
Scott McIntoshAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

jmcgOwnerCommented:
I've seen that message about "Failed to get the boot time ..." and it tracked down to being a WMI permissions problem. Does it happen to be the case that your Witness was placed on a Domain Controller?

You should be able to suspend-databasecopy before reboots and resume afterwards without getting the failed context index errors.
0
Scott McIntoshAuthor Commented:
It isn't on a DC.  I will check the permissions.
0
Scott McIntoshAuthor Commented:
What should the permission be for WMI on the witness server?
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

jmcgOwnerCommented:
Well, the normal recommendation is that "Exchange Trusted Subsystem" be added to the local Administrators group on the server hosting with Witness. That's problematic when the Witness is on a DC, which was what we were trying to do.

There's a lot more explanation in this article at 503sayhelo blog:

Tag Archives: File Share Witness

So if there are objections to the security implications of the normal recommendation, you can try giving this group the specific RPC/WMI permission needed to access the "time of last boot".

Before making changes, you should probably examine the event logs to verify that the failure you are seeing matches the pattern which this recommendation aims to remedy. The other thing to check is whether RPC is simply being blocked by a firewall.
0
Scott McIntoshAuthor Commented:
This item was not corrected.  With other issues appearing on the server, we rebuilt the entire DAG
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Scott McIntoshAuthor Commented:
Never solved.  I solved by reinstalling
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.