Users reporting delays in printing

I have just migrated a print server from Server 2003 to server 2012 with about 50ish printers attached to the new print server. All users are able to print. The issue is: Some users are reporting delays in printing by 10 seconds or so. The initial response after clicking print is, "Not responding" after a few seconds the print job goes to the printer. I have copied the same drivers and print settings from the 2003 server to the 2012 server, so I am not sure why there is this delay running print jobs.

Any help or suggestions would be much appreciated!
realtimerAsked:
Who is Participating?
 
Lionel MMSmall Business IT ConsultantCommented:
The 2003 drivers are not suited for 2012--you said you copied them over but they are more than likely incompatible with 2012, they may work but not optimally and that may be the cause for the delay.
0
 
Randy DownsOWNERCommented:
You may want to update the printer drivers for Server 2012. Is it all the printers or just certain ones?

To update or change printer drivers for a printer
Open Print Management.
In the left pane, click Print Servers, click the applicable print server, and then click Printers.
In the center pane, right-click the printer with the driver that you want to change or update, and then click Properties.
Click the Advanced tab.
Select a new driver from the Driver box, or click New Driver to install a new printer driver.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.