System.ServiceModel 3.0.0.0

I'm getting the following error in the application log hundreds of times a day (sometimes multile times a second and other times every 1 - 20 minutes or more). SBS 2011 Standard SP1.

Thank you for your help in advance

Log Name:      Application
Source:        System.ServiceModel 3.0.0.0
Date:          4/29/2015 2:58:08 PM
Event ID:      3
Task Category: WebHost
Level:         Error
Keywords:      Classic
User:          SYSTEM
Computer:      HCSO1.hcsheriff.local
Description:
WebHost failed to process a request.
 Sender Information: System.ServiceModel.ServiceHostingEnvironment+HostingManager/32001227
 Exception: System.ServiceModel.ServiceActivationException: The service '/Autodiscover/Autodiscover.xml' cannot be activated due to an exception during compilation.  The exception message is: This collection already contains an address with scheme https.  There can be at most one address per scheme in this collection.
Parameter name: item. ---> System.ArgumentException: This collection already contains an address with scheme https.  There can be at most one address per scheme in this collection.
Parameter name: item
   at System.ServiceModel.UriSchemeKeyedCollection.InsertItem(Int32 index, Uri item)
   at System.Collections.Generic.SynchronizedCollection`1.Add(T item)
   at System.ServiceModel.UriSchemeKeyedCollection..ctor(Uri[] addresses)
   at System.ServiceModel.ServiceHost..ctor(Type serviceType, Uri[] baseAddresses)
   at System.ServiceModel.Activation.ServiceHostFactory.CreateServiceHost(Type serviceType, Uri[] baseAddresses)
   at System.ServiceModel.Activation.ServiceHostFactory.CreateServiceHost(String constructorString, Uri[] baseAddresses)
   at System.ServiceModel.ServiceHostingEnvironment.HostingManager.CreateService(String normalizedVirtualPath)
   at System.ServiceModel.ServiceHostingEnvironment.HostingManager.ActivateService(String normalizedVirtualPath)
   at System.ServiceModel.ServiceHostingEnvironment.HostingManager.EnsureServiceAvailable(String normalizedVirtualPath)
   --- End of inner exception stack trace ---
   at System.ServiceModel.ServiceHostingEnvironment.HostingManager.EnsureServiceAvailable(String normalizedVirtualPath)
   at System.ServiceModel.ServiceHostingEnvironment.EnsureServiceAvailableFast(String relativeVirtualPath)
 Process Name: w3wp
 Process ID: 9728
ImImInAsked:
Who is Participating?
 
David Johnson, CD, MVPOwnerCommented:
To correct this problem enable the OWA Site IIS Anonymous Authentication. Run IISRESET and then validate the connection in OWA, remember that if there is a DAG in your environment you need to perform the procedure on all nodes.
0
 
ImImInAuthor Commented:
I went to IIS Manager and opened the IIDS-->Authenticaion app and noticed thqat the "Anonymous Authentication" is already enabled:

Screenshot-1.jpg
I wanted to check with you first to make sure this is correct before I tried the rest of your response.
0
 
ImImInAuthor Commented:
I went ahead and ran IISRESET (ran successfully) and checked for proper connection to OWA but this did not stop the event id 3 errors in the app log.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.