Encounter the error on Exchange 2007 server

Current I am in the midst of migrating from Exchange 2007 to Exchange 2013. Almost half of the total mailboxes have moved. Now, A internal users attempt to send mail to Exch2007 would get the error - 9667:

Failed to create  new named property for database "First Storage Group\Mailbox Database" because the number of named properties reached the quota limit (8192).

User attempting to create the named property: "Network service".
Named property GUID: xxxxxxx-xxxx-xxxx-xxx
Named Property name/id: "LastMessageWordCount".

Please help!
LVL 1
MichaelBalackAsked:
Who is Participating?
 
MichaelBalackAuthor Commented:
At the end, disabling 4 transport rules solve the problem. Please see attached for the 4 transport rules.
4-transport-rules.bmp
0
 
MichaelBalackAuthor Commented:
This is using MS Exchange 2007 SP3 with rollup 10.

I did try to up the quota limits to 32767 for Named Props Quota, NonMapi Named Props Quota, and replids quota, but failed to solve the problem.
0
 
Minecraft_ EndermanCommented:
We may turn up additional store logging within System Monitor to monitor Named Props table.
1. Start Registry Editor (Regedt32.exe).
2. Locate the Library value under the following key in the registry:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\Performance
3. On the Edit menu, click String , change the value from
c:\exchsrvr\bin\mdbperf.dll to c:\exchsrvr\bin\mdbperfX.dll , and then click OK .
4. Quit Registry Editor.
5. Start System Monitor, and select MSExchangeIS Mailbox Performance object.
6. Select "Rows in Named Props Table" and select the mailbox store we are monitoring.
0
Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

 
MichaelBalackAuthor Commented:
Hi Kiss Sky,

Now, not more event id: 9667 showing. Think maybe because the above 3 mentioned quotas took effect after a system reboot. However, internal mails from Exch2K13 to Exch2K7 is working, but not External incoming mails. I tried to send the external mail to any mailbox located at Exch2K7, and got the "agent failed" event registered in message tracking as attached in the bmp file.

No 3rd party anti-spam was installed here, except Kaspersky anti-virus. I have disabled the AV.
AgentFailed.bmp
0
 
MichaelBalackAuthor Commented:
Please see the details of agent failed as attached.
agentfailed-1.txt
0
 
MichaelBalackAuthor Commented:
please see get-transportagent as attached
get-transportagent.txt
0
 
MichaelBalackAuthor Commented:
Disabling the above 4 transport rules solve the problem. Some more, these 4 transport rules are redundant as this Exchange 2007 server is coexist with Exchange 2013, in which 2K13 is the main send/receive server.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.