Dell N3048 VLAN Configuration - Workstations Unable to ping VLAN IP Address

I am using a Dell 3048P switch.  I have created 3 VLANS (Data, Voice, Access Control).  I have assigned an IP address to each of the VLANs.  In CLI, I can ping all interfaces.  When I plug a workstation into the switch I cannot ping the default IP address associated with the VLAN.  I have confirmed the IP address of the workstation matches the IP subnet for the VLAN.  Not sure what to do from here.  Any help is greatly appreciated.
kwh3856OwnerAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

kwh3856OwnerAuthor Commented:
Here is the config:



console#show run

!Current Configuration:
!System Description "Dell Networking N3048P, 6.1.0.6, Linux 3.6.5-320b2282"
!System Software Version 6.1.0.6
!
configure
vlan 10
name "Data"
exit
vlan 20
name "Voice"
exit
vlan 30
name "Access Control"
exit
vlan 10,20,30
exit
slot 1/0 7    ! Dell Networking N3048P
stack
member 1 5    ! N3048P
exit
interface out-of-band
ip address 10.10.10.10 255.255.255.0 10.10.10.254
exit
ip routing
ip default-gateway 192.168.10.253
ip route 0.0.0.0 0.0.0.0 192.168.10.253 253
interface vlan 1
ip address 192.168.1.254 255.255.255.0
bandwidth 10000
exit
interface vlan 10
ip address 192.168.10.254 255.255.255.0
bandwidth 10000
exit
interface vlan 20
ip address 192.168.20.254 255.255.255.0
bandwidth 10000
exit
interface vlan 30
ip address 192.168.30.254 255.255.255.0
bandwidth 10000
exit
username "admin" password 5726e6082b17202ad7266d51380ab3fd privilege 15 encrypted
!
interface Gi1/0/2
switchport mode general
switchport general allowed vlan add 10 tagged
exit
!
interface Gi1/0/3
switchport mode general
switchport general allowed vlan add 10 tagged
exit
!
interface Gi1/0/4
switchport mode general
switchport general allowed vlan add 10 tagged
exit
!
interface Gi1/0/5
switchport general allowed vlan add 10 tagged
exit
!
interface Gi1/0/6
switchport mode general
switchport general allowed vlan add 10 tagged
exit
!
interface Gi1/0/7
switchport mode general
switchport general allowed vlan add 10 tagged
exit
!
interface Gi1/0/8
switchport mode general
switchport general allowed vlan add 10 tagged
exit
!
interface Gi1/0/9
switchport mode general
switchport general allowed vlan add 10 tagged
exit
!
interface Gi1/0/10
switchport mode general
switchport general allowed vlan add 10 tagged
exit
!
interface Gi1/0/11
switchport mode general
switchport general allowed vlan add 10 tagged
exit
!
interface Gi1/0/12
switchport mode general
switchport general allowed vlan add 10 tagged
exit
!
interface Gi1/0/13
switchport mode general
switchport general allowed vlan add 10 tagged
exit
!
interface Gi1/0/14
switchport mode general
switchport general allowed vlan add 10 tagged
exit
!
interface Gi1/0/15
switchport mode general
switchport general allowed vlan add 10 tagged
exit
!
interface Gi1/0/16
switchport mode general
switchport general allowed vlan add 10 tagged
exit
!
interface Gi1/0/17
switchport mode general
switchport general allowed vlan add 10 tagged
exit
!
interface Gi1/0/18
switchport mode general
switchport general allowed vlan add 10 tagged
exit
!
interface Gi1/0/19
switchport mode general
switchport general allowed vlan add 10 tagged
exit
!
interface Gi1/0/20
switchport mode general
switchport general allowed vlan add 10 tagged
exit
!
interface Gi1/0/21
switchport mode general
switchport general allowed vlan add 10 tagged
exit
!
interface Gi1/0/22
switchport mode general
switchport general allowed vlan add 10 tagged
exit
!
interface Gi1/0/23
switchport mode general
switchport general allowed vlan add 10 tagged
exit
!
interface Gi1/0/24
switchport mode general
switchport general allowed vlan add 10 tagged
exit
!
interface Gi1/0/25
switchport mode general
switchport general allowed vlan add 20 tagged
exit
!
interface Gi1/0/26
switchport mode general
switchport general allowed vlan add 20 tagged
exit
!
interface Gi1/0/27
switchport mode general
switchport general allowed vlan add 20 tagged
exit
!
interface Gi1/0/28
switchport mode general
switchport general allowed vlan add 20 tagged
exit
!
interface Gi1/0/29
switchport mode general
switchport general allowed vlan add 20 tagged
exit
!
interface Gi1/0/30
switchport mode general
switchport general allowed vlan add 20 tagged
exit
!
interface Gi1/0/31
switchport mode general
switchport general allowed vlan add 20 tagged
exit
!
interface Gi1/0/32
switchport mode general
switchport general allowed vlan add 20 tagged
exit
!
interface Gi1/0/33
switchport mode general
switchport general allowed vlan add 20 tagged
exit
!
interface Gi1/0/34
switchport mode general
switchport general allowed vlan add 20 tagged
exit
!
interface Gi1/0/35
switchport mode general
switchport general allowed vlan add 20 tagged
exit
!
interface Gi1/0/36
switchport mode general
switchport general allowed vlan add 20 tagged
exit
!
interface Gi1/0/37
switchport mode general
switchport general allowed vlan add 30 tagged
exit
!
interface Gi1/0/38
switchport mode general
switchport general allowed vlan add 30 tagged
exit
!
interface Gi1/0/39
switchport mode general
switchport general allowed vlan add 30 tagged
exit
!
interface Gi1/0/40
switchport mode general
switchport general allowed vlan add 30 tagged
exit
!
interface Gi1/0/41
switchport mode general
switchport general allowed vlan add 30 tagged
exit
!
interface Gi1/0/42
switchport mode general
switchport general allowed vlan add 30 tagged
exit
!
interface Gi1/0/43
switchport mode general
switchport general allowed vlan add 30 tagged
exit
!
interface Gi1/0/44
switchport mode general
switchport general allowed vlan add 30 tagged
exit
!
interface Gi1/0/45
switchport mode general
switchport general allowed vlan add 30 tagged
exit
!
interface Gi1/0/46
switchport mode general
switchport general allowed vlan add 30 tagged
exit
!
interface Gi1/0/47
switchport mode general
switchport general allowed vlan add 30 tagged
exit
!
interface Gi1/0/48
switchport mode general
switchport general allowed vlan add 30 tagged
exit

exit

console#
0
kwh3856OwnerAuthor Commented:
I have tried changing the port type from General to Access Port and that did not help.
0
StolsieCommented:
Hi kwh3856

Your port to devices should be access ports and have just the vlan for them going to it.
In the case of where you might have an IP phone then a desktop you would have it in general mode.
You would say
switchport mode general
switchport general allow vlan add 20 tagged (for phones)
switchport general allow vlan add 10 untagged (for data)
switchport general pvid 10 (no dell doesn't quite know the native vlan will be the untagged vlan lol, you have to tell it)

I hate to say it but with dell the best is to go in by GUI because it tells you what the status is of the ports and it is very easy for them to get themselves in a state where you can have two untagged vlans (3com suffers the same on some models)
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

LB1234Commented:
If you plug two pcs into the same VLAN ports, can they ping each other?  And to be clear, you've set each vlan to have an interface IP address?
0
LB1234Commented:
You have every single port in each VLAN tagged.  That isn't correct.  A tagged port is how one switch sends frames destined for another switch/vlan.  If this is all within the same switch, you don't need tagged ports.  You only need to give each VLAN an interface ip address, and set the gateway of the PC to that IP address.  Switchport mode should be access, not tagged.  Sorry, I'm coming from the Cisco world so terminology is different.
0
kwh3856OwnerAuthor Commented:
Thank you very much for your assistance.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Switches / Hubs

From novice to tech pro — start learning today.