ADFS Proxy servers DMZ

Hi, we have 2 ADFS proxy servers in the DMZ which are working fine and when using the GUI to access Remote Access Management Console can see the 2 proxy servers in there. But when clicking on the other proxy server to manage it from the same GUI am prompted for a username and password which says "Ensure that remote management is enabled on the selected server and then enter the username and password of an account that has administrator rights on that server" Have entered administrator credentials used to RDP to the servers but keep getting the windows security prompt back. Remote Management has been enabled on the servers in question

TIA
abhijitm00Asked:
Who is Participating?
 
btanExec ConsultantCommented:
It is advised for ADFS proxy in the DMZ, to be non-domain joined, in other words, stay with workgroup unless you have a separate management forest in the DMZ. It will have to keyed in the local admin for the ADFS e.g. <WORKGROUP>\<Local Admin username>... that is to assume that the Proxy Server can also resolve ADFS full FQDN name to the IP of the actual Federation Server. Also the Proxy in the DMZ and a firewall rule which allows communication over 443 between the Proxy and the Federation server only.

Just extending a bit more... If you, are able to authenticate from Intranet when talking to the ADFS server directly but FAIL when accessing ADFS via ADFS proxy, check the following:
a.   Time sync issue on ADFS server and ADFS proxy - Ensure that the time on the ADFS server and the proxy is in sync, when the time on ADFS server is off by more than 5 minutes, from that on the DCs, we get authentication failures. When the time on ADFS proxy is off sync as compared to ADFS, the proxy trust would get affected and broken, which will start failing the request coming via the ADFS proxy.

b. Check if the ADFS proxy Trust with the ADFS service is working fine. Re-running the proxy configuration may be a good option if you doubt that the proxy trust is broken.
0
 
AmitIT ArchitectCommented:
Server might be in workgroup. Better manage it separately.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.