This certificate will not be used for external TLS connections with an FQDN

hello

after i try to Enable-ExchangeCertificate i get this msg.

WARNING: This certificate will not be used for external TLS connections with an FQDN of 'IL-CAS1.ABC.local' because the
 CA-signed certificate with thumbprint 'E48EA0B3FE66DF65630E132E2D6EC9BB9FC6877E' takes precedence. The following
receive/send connectors match that FQDN: Default IL-CAS1, Client IL-CAS1, Relay.

From what I understand I should just delete the old thumbprint
Itzik HornsteinAsked:
Who is Participating?
 
Will SzymkowskiSenior Solution ArchitectCommented:
This certificate will not be used for external TLS connections with an FQDN of 'IL-CAS1.ABC.local'

You are getting this error message because it is referencing a .local domain which is not usable externally. If this is the old certificate then you can remove it. Also you need to make sure that you assign the appropriate services to your new certificate. Should look like below...

Enable-ExchangeCertificate -Thumbprint xxxxxxxxxxxxxxxx -services "pop,imap,smtp,iis"

Open in new window


Will.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.