Cannot access website from outside of network

Hello All;

I have 2 domain website that run from inside of my network.
One is accessible outside of the network (In the World Wide internet), the other is NOT.

The one that is not is www.wcff.net

I have checked the DNS and everthing looks and appears to be OK.
I have run several test,
http://www.intodns.com/
Reports that the (ERROR: I could not get any A records for www.wcff.net!)

https://www.dnssniffer.com/tools/dnscheck
Reports that it can access to A WWW record for the domain.

I have ran a tracert on it, through this site here
http://www.monitis.com/traceroute/

The first time that I ran the test, it ran for about 5 minutes, and did not show no results.
I tested my other domain, and it picked it up in about 104ms

Now, I can run the page with www.wcff.net, and it will load US in 84ms

I can access my site by use of a proxy, through here.
http://mirrorrr.appspot.com/www.wcff.net

However, if I try this site
http://nibbler.silktide.com/en_US/reports/www.wcff.net
It reports that it is not accessible.

I am really confused, as the Proxy site, picks up on my site, but nothing else does.

Can someone please assist and shine some light on this issue?
I would really like to get this resolved, as that when I start developing the site, I can also test it via mobile devices outside of the network.

Thank You
Carrzkiss
LVL 31
Wayne BarronAuthor, Web DeveloperAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

giltjrCommented:
When I go to  www.wcff.net  I get a page that says "Hello, I am a Radio Station"
0
matrix8086Commented:
That's because you need to add a record in you DNS "external" zone which respond to the requests from Internet

Check the DNS external zone for the other site, which is working, for an IP public address. The same A record with that public address must be configured in the wcff.net external zone

Best regards
0
Wayne BarronAuthor, Web DeveloperAuthor Commented:
@giltjr
Absolutely. Thank you, supposedly, you are the first person to view it outside of the network.

@matrix8086
All the records are nearly identical, except for one, that was missing in the wcff that the other domain had, and that was a PTR record. I have since created that one, (Information follows)

After reading both of your post, I decided to delete the zone and recreate it again.

I had to remember a few things that I had done before, that I had forgotten about.
Which was to create the PTR Record, so that is now in the zone.

I will give it until tomorrow, and will give everything a try and see what happens.
Thanks for your time all. Will post back my findings later on in the weekend.
0
Make Network Traffic Fast and Furious with SD-WAN

Software-defined WAN (SD-WAN) is a technology that determines the most effective way to route traffic to and from datacenter sites. Register for the webinar today to learn how your business can benefit from SD-WAN!

giltjrCommented:
I can still get to it.
0
Wayne BarronAuthor, Web DeveloperAuthor Commented:
Thank you giltjr
0
Wayne BarronAuthor, Web DeveloperAuthor Commented:
giltjr
Are you going to the actual URL (OR) are you using the Proxy link above?
www.wcff.net
(or)
http://mirrorrr.appspot.com/www.wcff.net
0
giltjrCommented:
I'm have been using just plain http://www.wcff.net.  That host name resolves to the IP address 216.97.166.158.

When you are having problems are you trying to access it from behind your firewall?  Is the host also behind the same firewall? If so, does www.wcff.net inside your firewall resolve to the public IP address or you private internal address.
0
Wayne BarronAuthor, Web DeveloperAuthor Commented:
OK. I finally got the wcff.net to show up on
Google Mobile-Friendly Test
&
I just went onto the Google Webmasters Tool.
And Verified the site through there, so that is AWESOME!

Now, I have 2 Static IP Addresses from my ISP.
One is the Router IP that is assigned to the Router.
One if the IP Address assigned to use for domains.
I add in a PTR for the Router IP, and that enabled the site to be seen through Google Mobile-Friendly and webmaster tools.



I am thinking that I HAD to have the Router IP Address as a PTR in order for the site to be seen.
I am still not seeing it through sites such as:
http://www.monitis.com/traceroute/
&
http://nibbler.silktide.com/en_US/report/submit

So I am going to stay on top of this, and make sure that everything goes good within the next day or so.
Since I created the other PTR record.

Any any suggestions on what else that I can try I would really appreciate it.

Oh, and yes, I know that I cannot access the site through the network, I have to use anything connection or user a Proxy to test these sites that I am building for running within my network, and hosting within my network, and not using an outside provider.
0
giltjrCommented:
I have never had to put a PTR record for a router.  There are only a few cases where a PTR record may be required and the only one I can think of is that some SMTP servers will do a reverse look-up to make sure that the domain name used in the HELO/EHLO command matches the domain name on the RCPT command.  

Google Webmaster tools does not require a PTR record.  I use Google Webmaster tools for a few sites that I know do not have PTR records for at least one of the sites.
0
giltjrCommented:
I just checked one of my sites that does NOT have  PTR record to it and Google Mobile-Friendly Test worked without any issues.  I also check out the same site using the two other links you posted and both worked without any problems.

I'm not sure what you original problem was, as I was always able to access your site even when you said you could not.
0
Wayne BarronAuthor, Web DeveloperAuthor Commented:
I know, I am as confused as you are.
I have to put the PTR record in my DNS in order for Google webmaster and Mobile-Friendly to see the site.
As before I did that, they would not see the site.

I just did a TraceRt test http://www.monitis.com/traceroute/
And it picked up on the site
US                =  84ms
Aisa/Pacific = 215ms
Europe         = No results at this time.

I have 10 different sites that are hooked into Google Webmaster, and neither of them, as for as I know, have a PTR on them. Then again, them sites are located on my Hosting Provider. I control the DNS through their DNS tools, at least the most part of it, and there are certain records that are automatic, that I do not have control over.

I still very confused as to what is going on here.
0
Wayne BarronAuthor, Web DeveloperAuthor Commented:
Update.
I just removed the External DNS from my Domain Controller Server
To my Backup Server DNS.
All my DNS records look good, and everything does a LOT better with it being OUT of the Domain Controller DNS.
I am going to give this a few days and see how it is working, and I will come in and post back and let you all know the outcome.

I hope this takes care of it, as i really need to start working on this site, within the next 2 weeks.

Just checked the site that was not showing up, and it is finally showing up!!!
http://nibbler.silktide.com/en_US/reports/www.wcff.net

About blasted time!!!
So, changing over the DNS Server to a NON-DC DNS, for the External DNS, did the trick

I am happy right now.
0
giltjrCommented:
When did you change the DNS server from a DC to non-DC.  Before or after I was able to view it on (May 1st).
0
Wayne BarronAuthor, Web DeveloperAuthor Commented:
The DNS for the external sites was sitting on the DC up until 4:30 AM EST
Once I changed it over to the Media Server's DNS, and pointed the port to that IP Address.
Everything came ALIVE.
All sites were able to view the DNS, and all issues that I was encountering, like the:
https://www.dnssniffer.com/tools/dnscheck
Reports that it can access to A WWW record for the domain.
IT now can access it without an issue.

So, what it was all along, was that the DC DNS was the cause of the issue the entire time.
Everything seems to be rockin and rolling, the way it supposed to be.
0
giltjrCommented:
"... DC up until 4:30 AM EST " what day?  Today?

I think there was more going on that just DNS.  Otherwise I would never had been able to see the site 2 days ago.
0
Wayne BarronAuthor, Web DeveloperAuthor Commented:
that was the only thing that i changed, was going from the DC DNS to the other Server DNS.
And then it all started working.
So, that is all that was done, for it to start working like it supposed to work.

It seems that you was one of the only people that could see the page up until now.
Now, other are seeing the page.
0
Wayne BarronAuthor, Web DeveloperAuthor Commented:
>>"... DC up until 4:30 AM EST " what day?  Today?
Yes, early this morning
0
Wayne BarronAuthor, Web DeveloperAuthor Commented:
This is going to be my last update, as this is the only thing that I can think of that fixed the issue.

Running DNS on a DC, and when you add in a domain for a website, this is what your SOA records basically looks like.

Primary Server:
Server-Name.domain-name.local
Responsible person:
hostmaster.domain-name.local

OK. you can change the "Responsible Person", however, you are unable to change the Primary Server.
I tried this several times, and every time it would ask me if I would to change this information, and I would choose "YES", it would change it back, once I closed out of the dialog.
This I think, was the issue, as when I would run the DNS test, on the sites mentioned several times above.
I would always get errors regarding the Primary Server

So, I went over to my Media Sever, and its DNS.
And I recreated the records there.
Changing the Primary Server to:
ns1.mynsdomain.com <--- This is my actual NS1 record (Named changed of course for demonstration purposes here).

And with this done, I updated the new data files, and then went back on to the DNS test sites.
And every one of them sites, responded perfectly.
And then I contacted a friend that had not been able to see the site, and he was finally able to pull it up,
As well as http://nibbler.silktide.com/en_US/reports/www.wcff.net
Which is one site, that could not see it at all before.

So.
It was a DNS issue, it was the SOA record that was causing the problem.

I have never run a Web Server and DNS on Windows 2003 DC. So this was new territory for me here.
I used to run a web, mail, and media servers from 2001-2008 and all the machines was NT4 Servers.
So having the other DNS Server, is what was needed.

DC DNS = > For the Members of the domain within the network.
Other DNS = > For web DNS

OK, that wraps it up.
I am going to close this one out, with this as the "Answer"
And since giltjr has been in here since day one, attempting to assist me
I am going to award him the points.

Thanks for the help.
This one is done!
I am happy to say

Carrzkiss
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Wayne BarronAuthor, Web DeveloperAuthor Commented:
I resolved the issue on my own, However, I did not want to close this one out, with just accepting myself as Answer, without giving something to giltjr for him staying in here and attempting to assist me. Even though none of his information really helped.
It is just the right thing to do.

Carrzkiss
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft IIS Web Server

From novice to tech pro — start learning today.