Exchange Migration 2007 to 2013

I exported the cert from ex2007 with private key and imported to ex2013.  I did the binding in IIS for port 443.  Now when open ecp, I get "this page cannot be displayed"  

make sure the web address https://servername is correct
look for the page with your search engine
Refresh the page in a few minutes
Make sure TLS and SSL Protocols are enable.  Go to Tools> internet option> advanced> settings> security

It was working fine before the cert install.  Any advice?
Joe JohnsonAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

MikeIT ManagerCommented:
Exchange 2013 will do this when it does not like the SSL Cert that was installed.  You will have to try and reinstall the cert using the Exchange Management Shell.  In the past I've actually had to purchase a completely new cert for it to take.
Will SzymkowskiSenior Solution ArchitectCommented:
With Exchange 2007 and 2013 co-existence you need an additional FQDN for 2007. So you should do the following...
- Generate a new CSR on the 2013 CAS server
- Add mail.domain.com, autodiscover.domain.com and legacy.domain.com
- import the cer/crt file on the 2013 server (make sure you allow the private key to be exportable)
- run the following command on the 2013 server (enable-ExchangeCertificate -thumbprint xxxxxx -services "pop,imap,smtp,iis")
- Export the certificate from 2013 and import it into all of your 2007 CAS servers
- perform the same Enable-ExchagneCertificate command (remove the old cert)
-  Update all of your virtual directories for both 2013 and 2007.

2013 virtual directories should use https://mail.domain.com/owa /ews etc
2007 virtual directories should use https://legacy.domain.com/owa /ews etc

I would highly recommend using Exchange Deployment Assistant for further steps.
https://technet.microsoft.com/en-us/office/dn756393.aspx

Will.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
SBS

From novice to tech pro — start learning today.