Can't join SBS2011 domain with http://connect

SBS 2011 server
Win7 workstation

When try to connect Win7 workstation I got these error (see attach file)

I have installed another workstation remote (RDP) using http://connect without problem.

I have check the solution in this answer
http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Windows/Windows_7/Q_27079430.html
I have check .NET installation, no problem

still got the error.   Dokument1.pdf

Any solution?
OleDAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

nwbrooksCommented:
You are probably running the Home version of Windows 7. Click Start, right-click Computer and click Properties. You must be running Windows 7 Pro or Enterprise to connect to a domain.
0
OleDAuthor Commented:
It's a Win7 Pro SP1
0
ktaczalaCommented:
Check and see if WMI is enabled and running.  I just had this exact same issue today.  is the PC in error belong to a workgroup?  I don't think you can go from domain to domain using http://connect.
0
Acronis True Image 2019 just released!

Create a reliable backup. Make sure you always have dependable copies of your data so you can restore your entire system or individual files.

joinaunionCommented:
Is it setup to allow RDP sessions?

Right click computer then select properties then on the left click on remote settings.
0
OleDAuthor Commented:
Best way to check WMI?

Yes, I can use remote desktop and login with local users.
0
ktaczalaCommented:
Services.msc
0
OleDAuthor Commented:
The services is missing.

How to reinstall/repair WMI?
0
ktaczalaCommented:
Wow! Try this experts exchange link:
http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Q_26905497.html

It should work for all versions of server.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
OleDAuthor Commented:
Thanks a lot ktaczala!!  Save my day! :-)

I still have problem after the connect program reboot the computer. I hangs on "welcome" screen.
It look likes problem with DCOM event id 10009
0
ktaczalaCommented:
Plenty of links if you search for that error.

Check your Networks settings.  make sure DNS points to server only.
0
OleDAuthor Commented:
WMI was not running. After WMI repair it works!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
SBS

From novice to tech pro — start learning today.