Exchange 2003 -> 2010 migration WITH shared email space on external server problems.

A customer has been using SBS 2003 for years, and since last November we've been in the process of migrating them to newer platforms.

This customer has an office in the UK (their HQ) and an office in Australia. Up until a couple of years ago, they had separate .co.uk and .com.au domains, but now they have consolidated into a single .com domain

They use FuseMail (formerly EPA) for mail filtering, so all inbound emails hit the FuseMail servers first. In the FuseMail portal, it is possible to perform user level routing, so there is a group for the Australian users and any email addressed to them gets routed to the Exchange server in Australia, all other emails gets routed to the UK office. All good on the inbound.

The UK office currently has the original Exchange 2003 server as part of SBS as it's main mail server. All users (with the exception of a test account) use this as their mail server.

I've been following some documents for the migration of Exchange 2003 to Exchange 2010, and MOST of if it works ok. The problem I have affects user accounts on the Exchange 2010 server only.

If I send an email to an external user, or to a UK based internal user, then the emails get delivered ok, BUT if I send an email to an Australian user on the same .com domain, I get an immediate NDR from Exchange 2010 saying that the user is unknown.

What I did, was to change the Accepted Domain for the .com address in Exchange 2010 from Authoritative Domain to Internal Relay Domain. From here on in, I was able to successfully send out emails to external and Australian users, BUT a whole heap of other problems then kicked in:-

Exchange 2003 started routing all internal emails out to FuseMail causing bounces etc., with no internal users getting emails from other internal users.
Inbound emails to UK users were being bounced because Exchange 2010 would not allow relaying

I need to be able to phase peoples mailboxes from Exchange 2003 to Exchange 2010 whilst retaining the ability / functionality of being able to send emails to users in Australia and without the problems above.

I've been able to reverse my above procedures, but even then, I had to stop and restart the Default SMTP Virtual Connector on Exchange 2003 in order for the queue to start clearing, but in with this, a lot of emails seem to have got lost in the ether somewhere.
LVL 17
Chris MillardAsked:
Who is Participating?
 
Simon Butler (Sembee)ConsultantCommented:
You need to make the changes on Exchange 2003 to share the SMTP address space.
https://support.microsoft.com/en-us/kb/321721/

Only once you have removed Exchange 2003 make the changes within Exchange 2010 to do things the way it wants to do.

The simple rule is to use the lowest version for major changes like this, as the later versions are backwards compatible.

Simon.
0
 
Chris MillardAuthor Commented:
Hi Simon,

I have followed Method 1, and since doing so, no one from the UK office can now email users in the Australian office.

Here's what I did:-

1) On the Default recipient policy, we had:-
     %g.%s@ourdomain.com <- This was the primary SMTP, and was set with "This Exchange organization is responsible for all mail delivery to this address."
    @ourdomain.local

I changed the primary SMTP to ourdomain.local (all domain users already have this in their email addresses)
I removed the checkbox against %g%s@ourdomain.com and saved the changes

2) Created a new policy called "Shared SMTP Space". Added the address of @ourdomain.com - set as primary, but did NOT set the "This Exchange organization is responsible for all mail delivery to this address" checkbox.

3) On the Messages tab of the Default SMTP Virtual Server, removed the FQDN entry from the "Forward all mail to unresolved recipients to host" field

4) Created a new SMTP Connector called "Shared SMTP Space".
Set the "Forward all mail to unresolved recipients to host" field to the same FQDN as I removed from step 3.
Set the bridgehead server to the Exchange 2003 server name.
Under the address space tab, added SMTP of ourdomain.com and checked the "Allow messages to be relayed to these domains" option.

5) Restarted the routing and SMTP services.
0
 
Simon Butler (Sembee)ConsultantCommented:
What happens when users attempt to send email? Does the email bounce, is it rejected with an NDR? Saying they cannot email doesn't really help with troubleshooting.

Simon.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
Chris MillardAuthor Commented:
Sorry. Yes the senders get an NDR:-

#550 5.1.1 RESOLVER.ADR.RecipNotFound; not found ##

If I telnet to the Exchange 2003 server, I get the same 550 5.1.1 Recipient not found after the RCPT TO: command
0
 
Simon Butler (Sembee)ConsultantCommented:
Have you got recipient filtering enabled on the Exchange 2003 server?

Simon.
0
 
Chris MillardAuthor Commented:
Hi Simon,

Yes - recipient filtering was enabled on Exchange 2003. I have disabled this, stopped and restarted the Microsoft Exchange Routing Engine and SMTP services.

Users on Exchange 2003 can now successfully email Australian users again, but still, users on Exchange 2010 get the same 550 5.1.1 Recipient Not Found error.

Chris
0
 
Chris MillardAuthor Commented:
Hi again Simon,

Just as a follow up, I have now tried setting the accepted domain on Exchange 2010 to Internal Relay Domain again, and so far it appears that the whole set up is now working as I had hoped with all internal UK users on both servers being able to email Australian users.

I'll run some more tests tonight and tomorrow and will report back.

Thanks
Chris
0
 
Chris MillardAuthor Commented:
Thanks Simon. All working.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.