Enterprise Deployment of RSA

I am trying to deploy RSA SecurID Software client out to all my Window workstations via GPO.  I have tried to deploy as software since the installation file that is provided is a MSI file but that results in just an error log on the client that says result is 1274 which just fails.  I also created a BAT script that I use on other applications that I deploy that uses the command line instructions provided in the guide.  When I run the BAT script locally it runs fine and installs the program but when I run it via the startup computer script it again does not work.  I suspect that this has something to do with the SYSTEM account that the GPO uses to install but am not sure if it is then what to do about it.  

The network share that I'm running the MSI from is the same share that I run other installations from.  The script that I've written works as I run it locally and everything is fine.  When I run a GPRESULT it shows the script runs fine but nothing of course is installed.  The guide says that it supports third party installers like MS System Center which is great but I don't run system center here and don't plan on purchasing it. I find it hard to believe the RSA hasn't been deployed via a GPO before but when I contacted support they said they were unable to help me with my issue and they pointed out that they support system center but not MS GPO deployment.
RSA-ver1.txt
SecurIDToken500Win-admin.pdf
David DonalsonownerAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

McKnifeCommented:
1274 doesn't have to be bad. it will also appear during a GPO background refresh.
It means, the system realizes "aha, there's something to install on next reboot - I cannot install it right now".

About the batch: running the install as system would work in over 99% of cases. So try to find out what is going on. if you don't know how to direct the errors to a result file, just run the install interactively as system:
1 download pstools and extract those
2 start and elevated cmd-shell by rightclicking cmd and selecting "run as administrator"
3 withing, run psexec -s -i cmd
--a second cmd opens, now with sytem rights--
4 withing, run your installer-batch and you'll see what is going on and we'll discuss the results.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
David DonalsonownerAuthor Commented:
That was a wonderful suggestion.  That really helped see the issue happening.  So based on what I was seeing with the command running as system, it was ending too quickly to get installed.  So I changed the command a little to not write a log entry on my network and the script then worked great.....So the issue is network permissions now.  

The NTFS permissions were all set correctly, the issue was the permissions for the share.  I didn't realize that none of my log directories have been working and this is the first script to fail because it couldn't write a log to the network share.   Just to double check that it worked, I also uninstalled then rebooted and the GPO successfully installed the RSA Application.  Thanks for the assistance.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2012

From novice to tech pro — start learning today.