Disable or remove NDR from public folders

Hi,

I've recently migrated our Exchange 2010 DAG to a Exchange 2013 DAG CU8, the migration went fine, mailflow is working as it should and so on.

But after migrating the public folders, I've begun to receive NDR mails, which i didnt before.

We are sending alot of mails from our systems (Using a SMTP service and a smart host) and these mails all have reply addresses which belongs to public folders so costumers can reply to them and our support team can handle incomming questions.

Some of these mails are sent to addresses that doesnt work, either because the addresses are typed wrong or the recipients have issues with their mail.

But we dont want to get NDR's because they are not being used for anything, so my question is if its possible to disable NDR's for public folders so they reject them when received or if they could be removed automatically.

I've tried with public folder assistant rules and also mailflow rules, for instance, if subject or body includes "Undeliverable: Mail Delivery Failure" then delete the message, but this does not work.

Does anyone have a good solution for this?

Thanks :)
Henrik HansenAsked:
Who is Participating?
 
Will SzymkowskiSenior Solution ArchitectCommented:
I guess you could just reference a transport rule in exchange to drop the message that a particular email address and specific key words in the subject or body. This does not however disable NDR's, just drops them after sending.

Will.
0
 
Will SzymkowskiSenior Solution ArchitectCommented:
You can only disable NDR's at the domain level and not at a mailbox level directly.

You would use the following cmdlet to stop NDR's for the domain.

The command below will turn off NDR's for all external domains.
Set-RemoteDomain -identity default -NDREnabled $false

Open in new window


If you only want to do this for specific domains then what you can do is create a new-remotedomain and then assign the parameters as you wish.

Will.
0
 
Henrik HansenAuthor Commented:
Hi Will,

Thank you for your answer, but i dont want to turn off NDR for all users, only for public folders, so i guess this is not an option.

Can a rule be created instead which deletes any incomming NDR's at arrival?
0
 
Henrik HansenAuthor Commented:
I've created multiple transport rules in ECP to catch the different types of NDR to this specific email address.

This solved the issue.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.