Outlook 2010 prompts for user name and password, with remote users connecting to SBS 2011

Remote users periodically receive a user name and password popup box in Outlook 2010, although Outlook still remains connected to the Exchange Server ( SBS 2011, running Exchange 2010 ).

Apparently this may be linked to an IIS, SSL setting, whereby 'client certificates can be set to ignore', but if so, where exactly is this setting in SBS 2011? Equally there may be another explanation and solution for this issue, which only affects remote users and occurs across multiple mailboxes / locations.

For reference, there is a purchased, current SSL certificate in place on the server for RWW and Outlook clients connect over http, with connecting using SSL and msstd:remote.xxxxxx in the settings.
LVL 1
itcroydonAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Simon Butler (Sembee)ConsultantCommented:
The setting is in the same place as it is on the full product - within the IIS management console under the SSL settings.
The authentication prompt do not always mean an authentication error. The client simply cannot cope with SSL prompts, such as those generated by a client certificate request.

The fix my network wizard should fix the issue, and the SBS BPA should flag it to you.

Simon.
itcroydonAuthor Commented:
I have checked under all IIS Sites and in all cases, SSL is already set to ignore. The fix my network wizard found an error code 3 which seemed to relate to IIS, but it found the same error again when running the tool a second time.

However there appears to be an autodiscover record pointing to the ISP rather than the server, which seems to be the cause of the issue. This randomly appeared on a test machine by chance!

Could you just confirm the correct syntax for an autodiscover record pointing to an SBS server and if any further action is required to make this work correctly?

Thank you for your help so far.
Simon Butler (Sembee)ConsultantCommented:
Depends on whether you have Autodiscover on the SSL certificate.
If you do, then Autodiscover.example.com should point to the Exchange server.
If you don't, then ensure that there are no wildcards in the external name, then configure an SRV record.
http://semb.ee/srv

Simon.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
SBS

From novice to tech pro — start learning today.