• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 247
  • Last Modified:

Internal WD Hard Drives come up as removable

After installing Win 7 Pro on this Pc with two 600 gig WD internal drives, the drives show up in the task bar as removable but they are not removable.

Motherboard is an Asus P8Z88 with an Intel i7-3770 processor.

Western Digital WD VelociRaptor WD6000HLHX 600GB

How do I resolve this so they don't get accidentally clicked and released like a flash drive?
0
Tony Giangreco
Asked:
Tony Giangreco
  • 4
  • 3
1 Solution
 
McKnifeCommented:
Try to release them - it does not work. There is no danger.
If you want to solve it, though, you will have to see what driver is causing this. Most probably it is the driver of the sata controller. - renew it.
0
 
DavidPresidentCommented:
That uses the Z68 chipset, which has enhanced SATA drivers.  They do not necessarily support all of the older windows O/S variations. Suggestion is to make sure firmware/BIOS of motherboard and all drivers are current.

There are also extra SATA slots for this feature, so make sure you plug the HDDs into the appropriate sata ports as described by the manual / release notes.

You do want to use the enhanced drivers and ports, btw.
0
 
Tony GiangrecoAuthor Commented:
Hi McKnife,

The 2nd drive was not initialized yet so I tested releasing it.  It did release and probably won;t show up again until i reboot.

I tried it on the C drive and it said it could not be released because it was in use - Yes, the O/S has it in use. This tells me they will release if Windows doesn't have any open files on the drive.
0
 
McKnifeCommented:
Ok, sure, it will work for data drives, but never for the windows drive. Windows will always have it locked.
0
 
Tony GiangrecoAuthor Commented:
I'd assume all internal drives should never release unless they are installed into a removable drawer and marked as a removable device in the system.  in this case, neither is true.

I've been using Windows 25 years and never saw this before.  

So, back to my original question: How do I set all internal drives to a non-removable status?
0
 
McKnifeCommented:
You cannot do that. The driver of the sata controller decides. Renew it. If that doesn't work, update your bios as well and report back.
0
 
Tony GiangrecoAuthor Commented:
I found a solution myself. There was an option on the drive controller in device manger that could be turned off. I made that change and the drives are no longer listed as being releasable.

Thanks for your suggestions.
0
 
Tony GiangrecoAuthor Commented:
I found a solution myself as stated above.   Thanks for your suggestions.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

  • 4
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now