Stop exchange 2003 routing to 2010

We are currently in co-existence with exchange 2003 and 2010, we have an issue where we route mail down a VPN to a smart host fax to email service, we are currently setting the connector up with the third party (complete from our side) so need fax to email traffic to still run from 2003, we had to restart one of our Exchange 2003 servers the other day and now fax to email has started routing through 2010 which is failing at the third party end, we want to ensure mail is still routed out of 2003 but it insists on using the 2010 connector, I have increased the cost of the connector on 2010 even disabled it but then we start seeing routing loops, need a quick fix to get this working again
Jon CarneyInfrastructure EngineerAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Guy LidbetterCommented:
Hi Jon,

How is the send connector currently configured on 2010?

Make sure that in the scoping that the "Source server" only has the Exchange 2003 Hub in it.
0
Jon CarneyInfrastructure EngineerAuthor Commented:
Hi, I'm actually trying to stop the 2003 server using the 2010 connector, it sends a PDF file to a fax to email service and at the moment if it goes through the 2010 connector it ends up corrupt on the other side so I've just got the 2010 server as source the 2003 connector has the 2003 server listed but it still insists on sending out the 2010 connector
0
Guy LidbetterCommented:
How is the connector actually configured? Do you have a specific Address space or Messaging type?
Are you using an exchange side Transport agent to recognize FAX traffic?

Otherwise

Remove the 2010 servers from the "Source Server" field in the connector.
It means all mail will be routed out through the 2003 HUB but removes the 2010 issue.

I'm assuming the FAX service is using a trusted IP to receive the mail which is why the 2010 mail is failing?
0
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

Jon CarneyInfrastructure EngineerAuthor Commented:
Address space is SMTP and address is a domain name so anything to that domain is routed down a VPN doesn't matter what type of message
if I remove the 2010 server from the source server on the 2010 connector won't the 2003 server still send mail to it?
0
Guy LidbetterCommented:
Only internally, as far as exchange is concerned for outbound mail, it will think the only route out would be via the 2003 hub.
0
Jon CarneyInfrastructure EngineerAuthor Commented:
yes it's using a trusted IP but the new mail server is added, the mail actually gets through fine it's just that the fax service reads the pdf as corrupt, thinking it may have something to do with the MIME type which is listed as application/octet-stream and not application/pdf
0
Jon CarneyInfrastructure EngineerAuthor Commented:
even though the originating email is coming from the 2003 system and being sent to the 2010 system?
0
Jon CarneyInfrastructure EngineerAuthor Commented:
just tried removing it from the connector and but it can't be left blank, no other servers to add
0
Guy LidbetterCommented:
So I can better understand the environment....

Are you using MDF devices?
Fax printer drivers?
2003 mailboxes?
0
Jon CarneyInfrastructure EngineerAuthor Commented:
no it's literally an outgoing email that is forwarded to a third party domain through a VPN the fax service is then handled by them so an email sent to (phone number)@domain.com with a PDF is then faxed to the number in the email, no devices or drivers, there are no mailboxes left on the 2003 system
there is a connector on the 2003 server that was being used to route the mail but for some reason its decided to route through the 2010 system even though it is named in the 2003 connector not the 2010......
0
Guy LidbetterCommented:
OK!

Back to your question regarding if you change connectors, will 2003 still send to 2010. No... as no emails originate from 2003. They all get sent to 2003 from the 2010 Hub.

You need two send connectors then. One for normal traffic with an address space of "*", and One with the Fax Domain. Make sure the "Scoped" option is NOT ticked on the same page.

The FAX connector must ONLY have the 2003 HUB as a source server, the other one only the 2010 Hub servers.

The FAX send must have a smart host configured (AS I am sure it is with the VPN)

Make sure you can see the FAX send connector on both 2003 and 2010.


You may already have done all this, but it doesn't hurt to check.
0
Jon CarneyInfrastructure EngineerAuthor Commented:
All other mail traffic is working fine from the 2010 system and has been for a while, the email for the fax is relayed to the 2003 box from an app server there is no mailbox for the email address, it's a public folder, the fax mail is usually just routed through itself as it has the connector so doesn't forward to 2010 the connector on 2020 was just to test the set up, can you see any issues in just deleting the connector on the 2010 box, 2003 should just then start routing back through itself (in theory).....
0
Jon CarneyInfrastructure EngineerAuthor Commented:
"2010"
0
Guy LidbetterCommented:
Which fax solution are you using?
0
Jon CarneyInfrastructure EngineerAuthor Commented:
Rebooted everything last night and it sorted itself out, pretty sure when we had to boot the 2003 server the other day it used the 2010 servers connector as an alternate route when it couldn't contact the server during restart and stuck with it.
Sorted now thanks.....
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Guy LidbetterCommented:
No Problems, glad its sorted.
0
Jon CarneyInfrastructure EngineerAuthor Commented:
Reboot sorted it
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.