issues with Nvidia K1 GPU on Vmware vSphere 6

We have a HP DL380 G9 with a Nvidia Grid K1

We have installed the VIB files & the x.Org Server is running.

We have deployed both Win7 & win8 VM's(VM tools deployed)  the K1 shows up in Device manager but I don't believe it's working.
dxdiag shows "VMware SVGA 3D" only.  
gpu dxdiagWhat am I doing wrong?

Thanks in advance.

Mark.
d_laroseAsked:
Who is Participating?
 
gheistCommented:
https:#a41451459 summarizes the problems
You get that 12-16 FPS on 1st video card via vSGA(aka xorg) or assigning 1/4 of grid to a VM. You can assign GRID K1 parts to 4 VMs and keep performance, or via vSGA get even slower 4x more cards. Later sort of allows more denser packaging, but essentially assumes most of guests will not use 3d acceleration.
grid k1 is a collection f four super-slow GPUs, i.e  ones that costed 10$ and never ran any CAD or game in their life.
0
 
Mr TorturSystem EngineerCommented:
Hi,
What make you think it is not working?
Maybe a little weird to me that you have 2 graphic cards for a VM, seeing standard driver and K1 specific driver, but it seems to be properly detected at least.
Did you test directx application on this?
0
 
d_laroseAuthor Commented:
I don't want two graphics cards.  I disabled the VMWARE one(in windows), with no change.

only test I've ran is the:

http://ie.microsoft.com/testdrive/Performance/ParticleAcceleration/

and I only get 12 or 16 FPS.

Attached is the settings for the VM.
win81.JPG
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
Mr TorturSystem EngineerCommented:
Ok.
I am not sure if disabling the standard card is a good idea, but i don't know about specific VMware configuration
to set with grid GPU.
Did you try with the auto-detect settings option?
Did you try to increase the video memory value? 128 is not really a high class size for video memory nowadays..
0
 
Mr TorturSystem EngineerCommented:
Do you have other options in PCI device 0 row in VM settings ?
0
 
d_laroseAuthor Commented:
Set now to auto, no change.
cannot modify any PCI options, all grayed out.

Oh and forgot to mention I keep getting "Nvidia Display settings are not available when trying to run nvidia control panel.

See attachments.
vidioauto.JPG
no-gpu.JPG
pci-options.JPG
0
 
d_laroseAuthor Commented:
yes, read all of those, but I'm not using vmware horizon.  is that really needed?
0
 
gheistCommented:
You must disable vSGA (the 3d tickmark aka VIB files)
for vDGA (PCI passthrough and NVIDIA CPL) to start working.

Also you must have one GPU configured for PCI passthrough over reboot.
0
 
d_laroseAuthor Commented:
not sure how you disable vSGA?

But I do have pass-though enabled.  see screen shot
vsga.JPG
0
 
gheistCommented:
video card - make sure 3D acceleration is disabled.
0
 
d_laroseAuthor Commented:
I've disabled it, same result.  see attachment.
3d-disabled.JPG
0
 
gheistCommented:
You also need to enable resources/reserve all memory and virtual hardware must be 9 or better.
Is it?
0
 
d_laroseAuthor Commented:
I believe this correct?
memory-res.JPG
0
 
gheistCommented:
Please power off machine and disable 3D, as it is enabled in other picture.
0
 
d_laroseAuthor Commented:
Here's current settings:
no-3d.JPG
0
 
d_laroseAuthor Commented:
One other thing I'm not sure of is the BIOS video settings?

let me know which one I should choose please.
bios-video.JPG
0
 
gheistCommented:
No idea, reset BIOS to defaults and dont touch anything.
PCI card gets through to VM, but you have 3D enabled in vmware so it ignores nvidia.
0
 
d_laroseAuthor Commented:
Enable 3d support is unchecked.  or am i missing something here?
0
 
rindiCommented:
I've never used VGA passthrough. As far as I know though, if you use passthrough, the device you want to pass through must be dedicated for that, and not used by anything else. But you mentioned that you have setup ESXi for X11. that would probably mean the card you want to use as pass-through is already used by X Org. That of course won't work. You must make sure the cardyou want to pass through isn't used by anything else. It must be dedicated for your VM.
0
 
gheistCommented:
X11 does not use passthrough cards.

vidioauto picture shows 3D acceleration via xorg active.
0
 
d_laroseAuthor Commented:
Ok.  I'm now confused?

I was told to enabled pass-though for the K1 deploy the .VIB files in the using the ESXCLI commands. with the x.org server running.

Yes, I have ESXI6 Vsphere deployed.

I just need my VM's running either Win7 or Win8 be able to run high end 3D CAD packages.
0
 
gheistCommented:
Each adapter and each guest machine can have one = passthrough aka vDGA ak nvidia cpl
 OR xorg aka vib aka vSGA aka svga3d
0
 
d_laroseAuthor Commented:
Ya, I know that.

this is the only way I have read about on how to enable the features of the GPU.  

What else is there to try?
0
 
gheistCommented:
You use unsupported .net client with vmx-11
Either get vmx-9 machine or change to vcenter web client. What you do cannot even remotely be made to work.
0
 
d_laroseAuthor Commented:
I've requested that this question be deleted for the following reason:

Solved
0
 
rindiCommented:
How did you solve it? Post your fix then select that as the answer.
0
 
gheistCommented:
The initial picture shows vSGA with real 3D adapter connected.
There could be only one. (in picture it works, Grid K1 is really weak low-end video card)
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.