WSUS - Setting Deadlines

Hi

I have a question on setting deadlines in WSUS.  What I've found so far is that deadlines are set on the patch level, but that doesn't jive with what I'm seeing in our environment (the person that set it up is long gone).  Can deadlines be set on a computer container also in the WSUS mgmt console?

What happened is that I moved a bunch of workstations from our old WSUS (that was apparently not installing patches) to our new using Wuauclt.exe /resetauthorization /detectnow (after changing the policy to point to the new server) and a bunch of people are getting their workstations rebooted multiple times today.   Just following bosses orders....

Thanks!

Tony
tonyjoewalkerAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Helao MwapangashaData Centre: Server EngineerCommented:
0
Helao MwapangashaData Centre: Server EngineerCommented:
0
Hypercat (Deb)Commented:
On the Options page, Automatic Approvals will allow you to create a rule that will set an automatic deadline. It can be set either for all or a certain WSUS group, and the deadline is a number of days after the approval at a certain time of day.  So, it seems unlikely that it would cause the workstations to reboot spontaneously, since normally it would be set for something like 3AM.  But you could check that setting to be sure.

There is also a group policy setting that controls whether the workstation can be rebooted automatically when someone is logged on. Perhaps you want to check and/or set this to prevent reboots while users are working on their computers:

Computer Configuration/Administrative Templates/Windows Components/Windows Update/No auto-restart with logged on users for scheduled automatic updates installations

If you turn this on, also look at:

Computer Configuration/Administrative Templates/Windows Components/Windows Update/Re-prompt for restart with scheduled installations
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Hypercat (Deb)Commented:
P.S. - I looked at the posts by Helao. It appears that setting a deadline manually per update will cause the reboot regardless of the "No auto-restart" group policy setting, so it sounds like that might be what is causing the behavior you're seeing.
0
tonyjoewalkerAuthor Commented:
thanks!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2008

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.