• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1230
  • Last Modified:

Disable Unified Messaging on mailboxes after the UM server has been decomissioned?

Hi there,

I have Exchange 2007, and noticed that I have more than a dozen user mailboxes are enabled for Unified Messaging. The only problem is that the UM servers were decommissioned about 3 years ago! So, I can't disable the UM feature on the mailbox via the GUI. I really need to do this so that I can migrate their mailboxes to O365, but as long as the UM feature is enabled and there is a UM address, I can't migrate.

I know I can export the mailbox to a PST, delete the mailbox, and recreate it (been there, done that on a few user mailboxes already)....but I'd really rather not have to go to that kind of trouble if at all possible. I'm hoping for an Exchange Management Shell command or something like that instead.

Thoughts?

Thanks,

Jonathan
0
JonathanSpitfire
Asked:
JonathanSpitfire
  • 5
  • 3
1 Solution
 
Helao MwapangashaData Centre: Server EngineerCommented:
try using the shell to remove the feature on the mailbox

https://technet.microsoft.com/en-us/library/bb124691(v=exchg.80).aspx
0
 
JonathanSpitfireSenior Solutions EngineerAuthor Commented:
No dice - I get the same error message in the shell:

Disable-UMMailbox : This task cannot be completed unless the Microsoft Exchange Unified Messaging service is running. Make sure that a Unified Messaging server is associated with the current user's dial plan "UMPlan" and that the Microsoft Exchange Unified Messaging service has been started on the Unified Messaging server.

Other ideas?

Thanks,

Jonathan
0
 
Helao MwapangashaData Centre: Server EngineerCommented:
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
JonathanSpitfireSenior Solutions EngineerAuthor Commented:
Helao,

Thanks, but that won't work. The server was uninstalled and removed from AD gracefully. When it was done, no one realized that UM was still enabled on this handful of users. It was apparently setup as a pilot and never put into full production, so everyone assumed it was safe to remove. even still removing the server from AD won't modify the attributes of the user mailboxes.

Thanks,

Jonathan
0
 
Helao MwapangashaData Centre: Server EngineerCommented:
0
 
JonathanSpitfireSenior Solutions EngineerAuthor Commented:
nope.
0
 
JonathanSpitfireSenior Solutions EngineerAuthor Commented:
This is so simple it is ridiculous:

Open ADSIEdit, drill down to the user, and clear these 4 attributes:

msExchUMEnabledFlags
msExchUMPinChecksum
msExchUMTemplateLink
msExchUMRecipientDialPlanLink

Go into Exchange and you will see that UM is now disabled for the user. Then you can delete the EUM addresses.

I only have a dozen or so users, so this is no big deal by hand. not sure how you would do a bulk operation, but that's all there is to it.

NOTE: there is a 5th msExchUM attribute: "msExchUMDtmfMap" I left this one in place because it was on all of my users, regardless of whether or not they had UM enabled.
0
 
JonathanSpitfireSenior Solutions EngineerAuthor Commented:
because my answer is correct, and no one else's was.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

  • 5
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now