SBS 2011 failing to start services, exchange, and AD after restart. (possible AD\permission issue)

Hello

We have an SBS 2011 which is very slow right now, restarting will leave it hanging on "applying computer settings" for hours before showing me login prompt. After i input credentials, it will stay on "applying user settings" for another 2 hours.


Once i am in, i am barely able to do anything.
i tried checking out if it were some services causing trouble. I tried step by step setting first exchange services to manual, then sharepoint (we dont use that), and trying to locate fault. But to no avail..

I noticed that the AD is not even responding properly, even though the AD services are running.

By the way, i can barely stop or start any of the services.  it always take a long time and gives me a error 1053.

I can't access \\domain.local and running dcgpofix gives me "Could not open the active directory object LDAP://rootDSE.

In safemode everything runs fast though.

I also tried running sfc /scannow, it just hangs (even after hours) and dism doesnt work either.

File replication service won't start. Same goes for:

Intersite messaging
Kerberos key distribution center
link layer topology discovery

It doesn't matter what service i try to start, when i try to start them it will try for a long time and then give me an error about not responding in a timely fashion.

I got access to event viewer if needed.
MzeidAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

MzeidAuthor Commented:
update:

After each restart, the server loses it's ip settings.. So i have to go in and set up ip, subnet, gateway again and again.
0
David AtkinTechnical DirectorCommented:
Hello, a few questions that may get us closer to a solution:

How long has the server been like this for?  

Does Safe Mode with Networking have the same result?

Have any updates or new software been applied since the problem started?

Have you verified that the RAID Status is ok on the server? - Can you confirm what RAID is in place?

Can you access the event logs?  Or copy the event logs onto another PC to access?

Any other Automatic Services not started?

Can users access the server via the network whilst this is happening?
0
MzeidAuthor Commented:
1. The applying settings part has been going on for almost 5 months or more. But we assumed that it was normal.
2. Safe mode with networking boots immediately.
3. No.  No updates.
4. It is running Raid 1. No issues.
5. I can access the event logs yes.
6. Yeah, a couple others but i can't access it now since i restarted. I just tried to set ip and gateway via Regedit, it remembers the ip settings now atleast.
7. The users can use the network shares (although super slow, and disconnects from time to time).
0
Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

David AtkinTechnical DirectorCommented:
What is the DNS Set to on your server?   Do these settings get retained on reboot?
0
MzeidAuthor Commented:
127.0.0.1
8.8.8.8

They are retained.
0
David AtkinTechnical DirectorCommented:
Remove the 8.8.8.8 address.  SBS should only look at its self. Any external lookups will be done via the DNS Server.

Can you confirm that DNS Server service is running on the server?

Do you have any Anti-virus software running on the server?

Can you check the Resources to see if anything unusual is maxing out the memory/CPU/DISk
0
MzeidAuthor Commented:
The DNS service is running.

The system log is filled with these errors.

Event system log
No antivirus running, although Avast is installed. I disabled it.

Nothing is maxing out really. Only exchange search service is going 10% sometimes.

And these errors (would just like to note that i allready tried disabling all exchange services and restarting. no luck)

Capture2.PNG
0
MzeidAuthor Commented:
and more:

File Server Resource Manager failed to enumerate share paths or DFS paths.  Mappings from local file paths to share and DFS paths may be incomplete or temporarily unavailable.  FSRM will retry the operation at a later time.

Context:
   Domain: SEMISTAL

Error-specific details:
   Error: DfsMapCacheAdd(Domain), 0x8007054b, The specified domain either does not exist or could not be contacted.


I am very sure it's the AD that is at fault here.

Because i cant access any AD stuff. not even user list from sbs console.
0
David AtkinTechnical DirectorCommented:
Do you get any errors when opening Active Directory Users and Computers?

Is Exchange used on the server?

Whats the status of your backups?

Can you also copy the Event View files off the server, zip them and upload them onto here?  I'll see if I can spot something obvious.

In Task Manager go to View> Select Columns.   Select Memory-Non-Paged Pool.   Put it in order of this and upload a screenshot.
0
MzeidAuthor Commented:
1. It just says that the AD Seminstal.local is not reachable.

2. Yes

3. I do have 2 weeks of backups, currently restoring the VHD image to a usb hdd from 2 weeks ago (earliest). Was hoping i wouldn't have to use this :)

4.Here you go. (note! i cleared some of them when i was troubleshooting yesterday.. sorry..)
Here is the first batch of logs.. I have to export them remotely, i cant login atm.

5. Cant login atm.
0
MzeidAuthor Commented:
logs.

had to upload it elsewhere.

https://userscloud.com/apqdx3jns7p2
0
MzeidAuthor Commented:
0
David AtkinTechnical DirectorCommented:
Sorry I don't know what that site is and its giving me dodgy popups.  You should be able to attach them onto here.  See below the post a comment box.
0
MzeidAuthor Commented:
trying again

keep getting

The extension of one or more files in the archive is not in the list of allowed extensions: logs/Application.evtx

when attaching :S

Uploading it to company server then..

http://backup.databoks.dk/obs/download/bothlogs.zip
0
MzeidAuthor Commented:
Currently restoring a systemstate backup..
0
MzeidAuthor Commented:
A Systemstate recovery helped. Thanks  David for the support  :)
0
David AtkinTechnical DirectorCommented:
Hello,

Did the System restore resolve the speed issues?

Dave
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
MzeidAuthor Commented:
The Systemstate helped bringing the AD up. Funny how a corrup AD can bring a whole server down to the brink of non functioning.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
SBS

From novice to tech pro — start learning today.