Exchange Server 2010 unable to send email with attachment larger than 20 MB

Hi,

My Exchange Server is somehow not allowing users to send out email greater than 20 MB to external email ?
Internally it works great with no issues.

I've also tried with 18 MB file to my free email account but it is rejected with the following error:
This message wasn't delivered to anyone because it's too large. The limit is 20 MB. This message is 25 MB.


Generating server: PRODHTCAS02-VM.domain.com
Test.Account@FreeWebHosting.com
mail.domain.com #550 5.3.4 SMTPSEND.OverAdvertisedSize; message size exceeds fixed maximum size ##

FYI: mail.domain.com --> is Symantec Messaging Gateway (Brightmail email appliance running as VM).

Any help would be greatly appreciated.

Thanks,
LVL 11
Senior IT System EngineerIT ProfessionalAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Senior IT System EngineerIT ProfessionalAuthor Commented:
Here's the settings on the HT-CAS servers:

Powershell Result
LeoCommented:
Do you have an option of breaking down the attachment in to two files of 10mb and then sending it across? if not, follow instructions on these two links....

http://exchangepedia.com/2007/09/exchange-server-2007-setting-message-size-limits.html 

https://support.microsoft.com/en-us/kb/2222370
Marwan OsmanCommented:
check the maximum message size on the device which has the role of sending emails out of your domain which is Brightmail email appliance in your case, it is cleared that it is configured to allow a maximum of 20 MB per attached.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

Senior IT System EngineerIT ProfessionalAuthor Commented:
Hi All,

The attachemnt is a PDF file and I also tried PPT file not compressed, so I don't know why Exchange told me it is larger than 20 MB ?

@Mario: What device ? it was sent through my laptop.
Marwan OsmanCommented:
what is the correct message size you are trying to send?
Marwan OsmanCommented:
I mean that the message is not denied from your exchange server, the Brightmail email appliance caused the issue and you need to check the message size limit on it, so please check out the below link to get help about the steps you need to follow to increase the message size limit on the appliance

https://support.symantec.com/en_US/article.TECH95239.html
Senior IT System EngineerIT ProfessionalAuthor Commented:
Ah yes,  How did you know if it was the Mail Gateway settings.

you are right: it is 20971520 bytes.

how come I didn't realize about that :-)

the actual file size is 18.3 MB (19,212,138 bytes) but for some reason it is still rejected.
Senior IT System EngineerIT ProfessionalAuthor Commented:
Does changethe limit / size can cause any unwanted outage ?
what is the size that I must match for both SYmantec and the Exchange  in the Screenshot below ?

Setting
Senior IT System EngineerIT ProfessionalAuthor Commented:
So what about the Transport Dumpster size ? do I need to change it into someother values ?
I don't have any DAG configured on both mailbox servers.
Marwan OsmanCommented:
Don't change other settings, change it to 30 MB in the symantec and wait for changes to be applied, leave it for 15 mins and try to send
Guy LidbetterCommented:
Hi There,

The attachment may well only be 18.3 MB (19,212,138 bytes), but the email itself will have a lot of overhead and metadata that it wraps everything up in, and it would easily push it over the limit.
Senior IT System EngineerIT ProfessionalAuthor Commented:
ok, so in this case I need to make it like the following:

"In/Outbound SMTP Configuration Maximum message size in bytes" in Symantec =  25 MB
"In/ExternalDsnMaxMessageAttachSize " in Exchange server = 20 MB

like 25 MB in total with added 5 MB as the buffer or inline attachment ?
Marwan OsmanCommented:
configure boss of them to 25 MB if you want to send 20 MB, or configure them to 30 MB if you want to be able to send 25 MB message, try this and inform if it does work successfuly or not
Senior IT System EngineerIT ProfessionalAuthor Commented:
ok, so if I configure that using powershell, do I need to restart or reboot anything ?
I wonder if it can be done during the business hours.
Marwan OsmanCommented:
it will be applied without restart
Senior IT System EngineerIT ProfessionalAuthor Commented:
What about the transport dumpster size ?

Since I do not have DAG configured somehow it is set as 50 MB from the default 18 MB by my predecessor would that limits the email size as well ?
Guy LidbetterCommented:
No it would not, no relation. However best practice says you should set it to a minimum of 1.5 times your max message size.
Senior IT System EngineerIT ProfessionalAuthor Commented:
Thanks !
Marwan OsmanCommented:
You are welcome Sir.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Active Directory

From novice to tech pro — start learning today.