• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 249
  • Last Modified:

procedure uses dbms_lob but get message needs to to be declared

What does this message mean?  Does the user I am logged into need to have execute privileges to use it in a procedure?  I tried to use sys.dbms_lob and I get the same message.
0
tangocoder
Asked:
tangocoder
  • 2
1 Solution
 
slightwv (䄆 Netminder) Commented:
Were you trying to execute dbms_lob inside a procedure or function?
Was execute granted on dbms_lob via a role?

If so, that is the problem.

Inside a stored procedure or function, you need to explicitly grant execute to the code owner not through a role.
0
 
tangocoderAuthor Commented:
Yes, I think that is the issue.  They always want to limit access of usage.  Thank you.
0
 
slightwv (䄆 Netminder) Commented:
>>They always want to limit access of usage

That is a good thing.  Minimal permissions should be the standard.  You just need to understand what can and cannot be granted through a role.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: Microsoft Exchange Server

The MCTS: Microsoft Exchange Server 2010 certification validates your skills in supporting the maintenance and administration of the Exchange servers in an enterprise environment. Learn everything you need to know with this course.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now