PowerPoint slide master bullet paragraph spacing issue

This is an odd one. The attached PowerPoint file has been stripped back to a bare minimum single slide master containing a single layout.

YOUpresent-Test.pptx

I'm trying to change the paragraph spacing from 1.5 to 1.0 in the layout (not the master above it).

It doesn't seem to accept it yet it's possible to change it in a slide created from the layout.

I even looked at the spacing via VBA before and after changing it to 1.0 and in both cases it returns 1.5 so it appears something is preventing the change?

ActiveWindow.Selection.ShapeRange(1).TextFrame.TextRange.Paragraphs(3).ParagraphFormat.SpaceWithin

Open in new window


If I use the format painter to pick up the format from another deck which doesn't exhibit this issue and apply it to the attached deck, it's fixed. But what is being changed?
LVL 14
Jamie GarrochPowerPoint Consultant & DeveloperAsked:
Who is Participating?
 
Echo_SCommented:
There are more issues than just the line spacing, Jamie. Note that the 2nd level text uses round bullets, but on that layout, the second level bullets use dashes. When you reset the slide or create a new slide, those also use bullets on first & second level text.

The formatting is kind of a mishmash between the master and the layout. All levels of text are round bullets (master), but the first 2 levels are blue round bullets (layout).

If you create a new slide and put in a 3rd and 4th and 5th level of text, it will not use the placement you see on the layout. It's closer to what you see on the master, but it's still not that, either. Someone's screwed up.

I'd say this is corrupt and I'd recreate the layout.

This is one of the reasons I don't "fix" templates for clients. I will rebuild them, but I won't attempt to fix them. :-)

Also, the layout is hard-coded to Arial font, and the master uses theme fonts. That's fine if that's what they want to do, but charts and smartart and tables and the default textbox and shape, etc., will all use the theme fonts so you may want to advise them that they're going to end up with a mix of Arial and Calibri throughout their decks.
0
 
JSRWilsonCommented:
Select the placeholder and run:

Sub chex()
Dim L As Long
Dim strReport As String
With ActiveWindow.Selection.ShapeRange(1).TextFrame.TextRange
For L = 1 To .Paragraphs.Count
strReport = strReport & "Para: " & CStr(L) & " Indent level = " & _
.Paragraphs(L).IndentLevel & vbCrLf
Next L
End With
MsgBox strReport, vbInformation, "Check Indent Levels are different"
End Sub

Open in new window


Spot anything?
0
 
Jamie GarrochPowerPoint Consultant & DeveloperAuthor Commented:
I get the same indent level output for the deck that I can change the paragraph spacing to 1.0 and the one that appears fixed to 1.5 e.g. 1/2/2/2?
0
Cloud Class® Course: SQL Server Core 2016

This course will introduce you to SQL Server Core 2016, as well as teach you about SSMS, data tools, installation, server configuration, using Management Studio, and writing and executing queries.

 
JSRWilsonCommented:
Maybe but the indent levels in a custom layout should be incremental shouldn't they?
0
 
Jamie GarrochPowerPoint Consultant & DeveloperAuthor Commented:
I believe it's a client design choice to keep only two 'visual' levels. But it's very odd that in the 4:3 template, the paragraph spacing can be set to 1.o but in this one it can't. I have a fix (the format painter) but it's bugging me not knowing what is preventing the user change to 1.0!!!
0
 
Echo_SCommented:
Don't use format painter! At least, don't do it usually. Format painter add bullets to subtitles and other weirdness. Of course I understand in this case it might be your only option. I'll try to remember to download that file and take a look.
0
 
Jamie GarrochPowerPoint Consultant & DeveloperAuthor Commented:
I've not managed to get to the bottom of this one so if anyone still wants to have a go in understanding what's wrong with the above attached file...
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.