Hyper-V second generation server unhappy

I shut down a Hyper-V host to move it to a new rack, unfortunately when it was rebooted it was not connected to a network.

One of the systems is not happy. I cannot connect to it remotely or ping it.

It says it is running but when I try to access it from the console could not send keys it will not accept the keys

Shutdown from the console does not work: Shutdown ineffective.

Any more ideas?
LVL 16
Carol ChisholmAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Lee W, MVPTechnology and Business Process AdvisorCommented:
Hard power off to the VM ("Stop" it).  Then turn it back on.

Hope you have backups. (Doesn't mean I think you'll need them, but sometimes weird stuff happens - I won't necessarily think this is Hyper-V's fault either).
0
Carol ChisholmAuthor Commented:
It does not Stop...does not stop
I have backups. It's DC and I have another one. I have moved the FSMO roles. I am building another...

I can also copy the VHD...

It autostarts, and then gets in this unhappy state otherwise I would just delete it and make a new one.

I think the network cables got plugged in in the wrong order.

Can I disable the Hyper-V service reboot the host and somehow turn off autostart?
0
Lee W, MVPTechnology and Business Process AdvisorCommented:
Have you tried adjusting the Automatic start action and rebooting the server?

I would wonder if the Hyper-V config file got corrupt - I might try to delete the vm and then recreate it using the existing VHD(x) files for the hard drives.  If you must, reboot the server to a Windows disk and rename the folder that stores the VM - that should prevent it from starting.  Or, simply disable Virtualization in BIOS.
0
Carol ChisholmAuthor Commented:
I could not adjust anything. I could not delete the VM either.
Since the server is miles away rebooting to a disk was not an option.

However I did solve the problem by adding management access to the virtual switch, which seemed to unlock it. I could then access the machine perfectly.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Carol ChisholmAuthor Commented:
I found the solution myself.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2012

From novice to tech pro — start learning today.