Turn OFF : Do You Want To Open or Save This File in IE for XLS Files

Can I turn OFF : Turn OFF : Do You Want To Open or Save This File in IE for XLS Files? ,

1.Launch Registry Editor (Start >> Run >> regedit.exe)
2.Expand HKEY_CURRENT_USER
3.Navigate to HKEY_CURRENT_USER \ Software \ Microsoft \ Windows \ Shell
4.If it doesn’t exist, create the AttachmentExecute key
5.Create the {0002DF01-0000-0000-C000-000000000046} key
6.Create a new Binary Value with the Name ******************* (USED : Excel.Sheet.8 )

DIDN'T Work.

???
?
LVL 4
mvalencia2003Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

BillDLCommented:
What version of Microsoft Office do you have installed?
What version of Internet Explorer are you using?
What Operating System are you using?

Are you trying to change this setting only for yourself on one computer, or for multiple users on different computers?

Do you want XLS files to open automatically in an external instance of Excel, or inside the Internet Explorer window?

Here's a link to an Excel 20013 *.XLS test file that I have attached:
Test.xls
0
mvalencia2003Author Commented:
Office 2010
IE 9
Win 7

one computer ,
click on report link and instead of asking to open , save , or cancel ... JUST have it open automatically.  Also, sometimes have to click Retry (download) 2-3 times before it allows it to open...

???
0
BillDLCommented:
Try this and see what happens:

1. Click on a link to an Excel file and choose "Save".  Allow it to download.
2. Tools button > "View Downloads" or Ctrl + J to open the Download Manager window.
3. RIGHT-Click the file you just saved that has the file extension you want to open automatically in future.
4. Uncheck the "Always ask before opening this type of file" box.
5. Close Internet Explorer and restart it.

See what happens and let us know.
0
Cloud Class® Course: CompTIA Healthcare IT Tech

This course will help prep you to earn the CompTIA Healthcare IT Technician certification showing that you have the knowledge and skills needed to succeed in installing, managing, and troubleshooting IT systems in medical and clinical settings.

Sudeep SharmaTechnical DesignerCommented:
Hi mvalencia2003,

I tried the same steps for editing the registry and I am NOT getting any dialogue and XLS file is opening without any prompt for me.

I tried the file attached by BillDL above.

1.Launch Registry Editor (Start >> Run >> regedit.exe)
2.Expand HKEY_CURRENT_USER
3.Navigate to HKEY_CURRENT_USER \ Software \ Microsoft \ Windows \ Shell
4.If it doesn’t exist, create the AttachmentExecute key
5.Create the {0002DF01-0000-0000-C000-000000000046} key
6.Create a new Binary Value with the Name : Excel.Sheet.8.

My System is WIndows 7 Professional 64bit, Office 365 Professional Plus (Office 2013) and IE 10.

I have exported the part of the registry, so that you could import it to your system as well to see if that makes any difference.

Remove what you might have created, make sure that IE is not running at the time when you do this.

Copy the text in between line, paste it to the notepad, save it as .reg file and run it "As Administrator" to merge it on your system.
=====================copy below this line========================
Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Windows\Shell\AttachmentExecute\{0002DF01-0000-0000-C000-000000000046}]
"Excel.Sheet.8"=hex:
=====================copy above this line========================

Sudeep
0
mvalencia2003Author Commented:
tried :
Uncheck the "Always ask before opening this type of file" box .. = NOT there ,
-

?
0
mvalencia2003Author Commented:
this is a web based application for ordering items , reports/orders open in excel .. does this have anything different as to a regular site (trying to open an Excel file) ..???
0
Davis McCarnOwnerCommented:
This article says changing the settings for Excel (or whatever) to always run as administrator fixes it; but, it is a possibly dangerous path as your users will be able to open and run any infected file they see in the future: http://smallbusiness.chron.com/fix-always-ask-before-opening-type-file-60489.html
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Web Browsers

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.