Windows 2008 DNS Server Question

Hello Experts,

I have configured my DNS server to respond to DNS queries from a specific interface,(10.1.30.140), see image.
dns
But whenever I ping the dns servers hostname (n30-dc) I keep on seeing the response from 192.168.99.140
dns2
Can someone let me know if I need to make a change on the Windows 7 client or on the PC - bear in mind I have configured the client with DNS of 10.1.30.140, see image.
dns
cpatte7372Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

scriven_jCommented:
OK - so in the example given, PING is accessing DNS to look up an address for N30-DC and being given 192.168.99.140 which is the address it is then sending ICMP (ping) traffic to.

This is different to which DNS server it is accessing, but instead indicates what information the DNS server is giving out for N30-DC. (i.e. What N30-DC resolves to.)

Use NSLOOKUP at a command prompt to see which address is actually serving up DNS queries.

If you don't want that other IP address to come up in pings then you need to delete the A record for N30-DC which points at 192.168.99.140 or change it to point at the other IP address if you want to change this behaviour.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Radhakrishnan RSenior Technical LeadCommented:
Hi,

Since you have given the preferred DNS address as 10.1.30.140 it should try to contact this DNS server eventhough you selected the "defined address". What happens if you set the client machine to get dynamic ip's (DHCP). Is that getting the 10.xxx address as DNS?

If you still need static IP then the better option would be set the other DNS server for the client machines.

Hope this helps.
cpatte7372Author Commented:
Hi Chaps,
Going to try your suggestions now...
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

cpatte7372Author Commented:
Scriven,

This is the output of nslookup
dns
Are you suggesting that I remove 192.168.99.140 from here
dns
Radhakrishnan RSenior Technical LeadCommented:
"Are you suggesting that I remove 192.168.99.140 from here" No, don't delete anything in the DNS console. Try to change the DNS address on the client machine (NIC properties).
Radhakrishnan RSenior Technical LeadCommented:
Also the DNS doesn't seem to have A record for 10.1.30.140. This is the reason it's showing as "Unknown". If DNS A record is missing for the 10..series IP then please add it.
cpatte7372Author Commented:
Rad,

The A record for 10.1.30.140 is shown in the image above ... or am I going crazy :-)
cpatte7372Author Commented:
Experts,

I thought I would add this image as well,,,

dns
cpatte7372Author Commented:
Some help pleasa
scriven_jCommented:
Delete the A record that points at 192.168.99.140 and replace it with a CNAME record that points at the FQDN for that server.

Looks like you should do it at the level above where you are from the screenshot.
Manojkumar RaneCommented:
Remove the 192.168.99.140 IP from DNS and also uncheck the register this NIC option from NIC setting where you configured this IP.
Then run ipconfig /flushdns and ipconfig /registerdns command from command prompt.
cpatte7372Author Commented:
Manoj, I tried your suggestion and it didn't work. I'm not sure what you mean about unchecking the NIC.

Scriven, going to try your suggestion now.
cpatte7372Author Commented:
Scriven,

I tried your suggestion and I get the following error:

dns
cpatte7372Author Commented:
Manoj,

Where do you register a NIC?
scriven_jCommented:
There must still be a record with that name already?

I've just looked back at your previous posts though and the NSLOOKUP screenshot shows that the DNS server being used was the 10.1.30.140 address that you thought wasn't being used?
Manojkumar RaneCommented:
Go to network connection -- NIC properties -- select Internet protocol Version 4 (TCP/IPv4) -- Properties -- Advance -- DNS tab --  Uncheck register this connection's addresses in DNS.
Network.JPG
cpatte7372Author Commented:
Manoj,.


I followed your instructions exactly as described, but it failed, see image.

dns
cpatte7372Author Commented:
Scriven

DNS server being used was the 10.1.30.140 address that you thought wasn't being used?

The nslookup was run from the Client PC. This is what it should be using but as you can see it replies with 192.168.99.140.
cpatte7372Author Commented:
OK Experts,

I have two interfaces on the DNS server, 192.168.99.140 & 10.1.30.140. When I ping the servers hostname, n30-dc it returns with ip address 192.168.99.140, however I need it to return with ip address 10.1.30.140. If I disable interface with ip address 192.168.99.140 the reply fails, but it should come back with 10.1.30.140.

There must be a simple explanation.
cpatte7372Author Commented:
scriven

I have created the cname as suggested, but it still fails...

dns
Radhakrishnan RSenior Technical LeadCommented:
Hi,

First of all you are getting "Unknown" status of DNS while performing nslookup from the client which might need attention. I would suggest to do the following steps;

1) Delete the A record of 10.1.30.140 and recreate it along with associated ptr records which pointing correct FQDN of the server.

2) Since you have 2 NIC's, you need to change the Interface metric setting to higher than the other network card, so that it will take precedence. To do this, Start>>run>>ncpa.cpl>>select the network card and properties>>Internet Protocol Version (IPv4)>>Properties>>Advanced>>In the downside there will be a check mark box which shows automatic metric>>Is this ticked? or set manually? if it is manually set metric then change the value to higher level and test. You need to test with different value till you get the correct response.
cpatte7372Author Commented:
Hi Rad,

I think you're on the right track. I will try your suggestion now.
cpatte7372Author Commented:
Rad,

Are you suggesting that I change the NIC precedence on the client or the server?
Manojkumar RaneCommented:
Remove all entries of IP 192.x.x.x from DNS which is pointing to your server hostname and then try to ping the server.
cpatte7372Author Commented:
Manoj,

Remove all entries of IP 192.x.x.x from DNS which is pointing to your server hostname

On the server or client?
cpatte7372Author Commented:
Rad,

I have change the NIC precendence on the DNS server as shown in the image, and it still doesn't work...
fdg
cpatte7372Author Commented:
This is crazy.

I'm sure I'm not the only person that has had this problem.

There must be an Expert that has encountered this problem in the past/
cpatte7372Author Commented:
Experts,

Please help
Radhakrishnan RSenior Technical LeadCommented:
Did you re-created the A record? if not, please re-create and see still you are getting Unknown status while performing nslookup.
cpatte7372Author Commented:
Rad,

Do you mean both A records shown here?
dfd
cpatte7372Author Commented:
Rad,

Did what you suggested and still it fails...
Manojkumar RaneCommented:
On server you need to remove all records which is point to IP 192.x.x.x.
Then run nslookup from client machine. Client machine should resolve IP 10.x.x.x
cpatte7372Author Commented:
Manoj,

I have searched everywhere on the server for any records pointing to 192x.x.x. and there is none.

But still the client machine returns unknown and resolves to 192.168.99.140. However, if I do a ping -a 10.1.30.140 it comes back with the server same .... I don't understand??
sdfed
cpatte7372Author Commented:
OK,

So I completely disable DNS service and I was still able ping hostname n30-dc. How is that possible? And it still returns 192.168.99.140 as shown in the previous image - how is that possible?
cpatte7372Author Commented:
Experts,

This is what I get when I run nslookup on the dns server itself:

fds
Does this suggest DNS server isn't running at all? Even though the DNS services are running?
cpatte7372Author Commented:
Sorry for the confusion - DNS service is now running, but it wasn't running a short while ago and I was still able to ping n30-dc.

I really don't get it!
Radhakrishnan RSenior Technical LeadCommented:
Hi,

As i mentioned earlier, it seems the server doesn't have ptr records for that IP address (10.1.30.140). Manually create a ptr record and check nslookup. You can follow this procedure http://www.randika.info/2013/01/how-to-fix-nslookup-default-server.html
cpatte7372Author Commented:
Hi Rad,

Thanks for the link.

It seems like a need to create a new zone. Do you have a similar link showing how to create a new zone?

jk
Cheers
cpatte7372Author Commented:
Hi Rad,

I think we're almost there. nslookup is now seeing my server, but its still returning the ip address 192.168.99.140.

dfd
Radhakrishnan RSenior Technical LeadCommented:
Hi,

On the server, disable the network card where you configured 192.168.99.140 address. Once you done that, go to your client machine and make it to get the IP automatically instead of static. Reboot the machine. Perform
ipconfig /release
 ipconfig /renew
ipconfig /flushdns
ipconfig /registerdns

Now test the output. If that doesn't work I am sorry i am out of ideas.
cpatte7372Author Commented:
Hi Rad,

Thanks for your help.

I tried your suggestion - I even disabled the interface on the server with ip address 192.168.99.140.

I can see the server with nslookup, but when I try to ping the server name nothing happens.

add
Thanks for your help. May another Expert can pitch in
Natty GregIn Theory (IT)Commented:
if you change the ip address of the dns server, you need to reauthorised it in the dhcp server as long as dhcp is dishing out ip addresses, its also responsible for the dns and published that address also. after authorization it will write a new A record. after which you can delete the old one. Server must be rebooted
cpatte7372Author Commented:
Cheers
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 7

From novice to tech pro — start learning today.