'Send as' permission not working in Outlook. Exchange 2010.

Hi,

We are facing an issue where we have assigned 'send as' permission to User ABC so that he can send mail as user XYZ.

It is being observed that whenever ABC user sends mails as XYZ it is successfully send from browser (OWA).However, If the same task is being performed from MS Outlook then ABC receives an Undeliverable email saying that the user does not have permission.

We have used powershell commands to assign permission and ABC user is having full access of XYZ.

Kindly help this is very urgent....
rigelnetAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Viral RathodConsultantCommented:
There are two possibilities,

1) MS Outlook in Cache Mode  - Uncheck and recheck Cache Mode Option.
2) Recreate MS Outloook Profile.- Try to recreate profile
0
rigelnetAuthor Commented:
Profile is already recreated. (Cache mode uncheck and recheck was done as well).

Data has been synced all over from the server. Still the issue persists.
0
rigelnetAuthor Commented:
User is working on MS office 2010 SP1.
0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

Viral RathodConsultantCommented:
After giving “Send-As” permission for the user,you have to wait for few hours.

If you do not want to wait then run following commands to make the changes effective immediately.

Clean-MailboxDatabase  -Identity "user-database-store"

OR

Restart Information Store Service.

Also Is XYZ mailbox hidden from GAL ?
0
rigelnetAuthor Commented:
I have restarted the Informatioin store service also I have tried below solution from one  of the link but no luck.

1. Close Outlook
2. Delete the offline address book folder under “C:\Users\username\AppData\Local\Microsoft\Outlook\Offline Address Books”  (I assume it’s Windows 7 computer, look under C:\documents and settings\username\…. for XP computers).
3. Open Outlook and let it download new OAB.
0
rigelnetAuthor Commented:
Also I found this solution: User’s Outlook got bad/outdated cached contact information. Search for *.NK* files under user’s profile and delete it. Obviously Close the Outlook first before you delete the *.NK* files.

But I am not able to find .NK files. Can you provide me the path for the .NK files?
0
Simon Butler (Sembee)ConsultantCommented:
Outlook 2010 doesn't use nickname files. You are reading a solution for an older client.
Outlook 2010 SP1 is also very old - you should upgrade to Outlook 2010 SP2, then run Microsoft Update to patch the client.

Saying that though, it shouldn't make any difference. Ensure that you have not tried to set Send on behalf of permissions as well, and that the permission hasn't been removed from the account (if the user is an administrator, power user etc then the permission can be removed).

Simon.
0
rigelnetAuthor Commented:
I have installed Office 2013 and the same issue still persists.

The permissions are only for "send as" and send on behalf is not even touched.

There is no doubt that permissions are properly assigned since 'send as' is working like it should be while using browser/owa.

Kindly let us know what needs to be done to solve it on outlook.
0
Will SzymkowskiSenior Solution ArchitectCommented:
Have you tried to create a new WINDOWS profile and test again? I have seen many times where it is the actual Windows profile that creates issues with how Outlook functions.

Will.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Marwan OsmanCommented:
I have faced this problem before, and it is solved when we go to the new email, and in the from tab we select from "other email address" and type the email address manually, try it !!!
0
rigelnetAuthor Commented:
Thank you
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.