error when client PCs try to connect to WSUS server

Following on from a previous question:

http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Windows/Windows_8/Q_28664361.html

I am having problems connecting to WSUS server (server 2012 r2) from a client PC.

The error I am getting is 80072EFE. I can ping the WSUS server from the client.

I have only recently set up WSUS and currently have no clients connected to it.

Does anyone have a suggestion.
LVL 1
roy_battyDirectorAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

McKnifeCommented:
In your previous question, you didn't yet answer my question about the regfile that you use to configure your test client. Did you use the FQDN form for the servername, like wsus.yourdomain.local?
*** Hopeleonie ***IT ManagerCommented:
Did you try this Fixit?
http://go.microsoft.com/?linkid=9830262
Seth SimmonsSr. Systems AdministratorCommented:
it's not working because the registry value McKnife posted in the other thread is incorrect
the server is specified with no port
by default 2012/2012 R2 uses port 8530 and SSL on 8531 - the values there does not specify a port which means it's trying to communicate on port 80 which won't work
change that value from

http://wsus.mydomain.local

to

http://wsus.mydomain.local:8530

restart windows update service and see if it works

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
McKnifeCommented:
Seth is right, the default port changed with later versions.
roy_battyDirectorAuthor Commented:
Perfect. That fixed it. hanks for the help.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 8

From novice to tech pro — start learning today.