vmx File locked during backup using veeam 7.0

Dear Experts,

We are having 4 x ESXi 5.1 servers in cluster with one VCenter, For backups we are using Veeam backup and Replication 7.0.

we are getting error on most of the virtual machines, The error is:

 Processing 'DC' Error: Client error: File does not exist or locked. VMFS path: [[EqualLogic-SAN] DC/DC.vmx]. Please, try to download specified file using connection to the ESX server where the VM registered. Failed to create NFS download stream.

I have tried following things:

1) Re create backup jobs
2) migrate vms to different servers ( worked for some time and then the error comes back)
3) restart esx servers

Before everything was working fine, Kind support will be really appreciated.

Thanks and Regards
Zaheer Ahmad
Backup-Job-1.zip
MCIT-LibyaAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

pgm554Commented:
Check out the troubleshooting guide from Vmware for locked machines:

http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=10051

Locating the lock and removing it
A virtual machine can be moved between hosts, because of this the host where the virtual machine is currently registered may not be the host maintaining the file lock. The lock must be released by the ESX/ESXi host that owns the lock. This host is identified by the MAC address of the primary management vmkernel interface.

Note: Locked files can also be caused by backup programs keeping a lock on the file while backing up the virtual machine. If there are any issues with the backup, it may result in the lock not being removed correctly. In some cases, you may need to disable your backup application or reboot the backup server to clear the hung backup.

This lock can be maintained by the VMkernel for any hosts connected to the same storage.
MCIT-LibyaAuthor Commented:
Dear pgm554,

Thanks for information, it turned out to be DNS issue, all settings were OK but still ESX Servers were not resolving by veeam, i added all esx servers in my host file and it worked fine now.

Thanks and Regards

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
MCIT-LibyaAuthor Commented:
I got this link via veeam support:

http://www.veeam.com/kb1198

It helped to resolve my problem.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
VMware

From novice to tech pro — start learning today.