• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 153
  • Last Modified:

Puppet : Failure to get node definition

Hello,

I'm getting the error on the Windows puppet node:

"Warning: Unable to fetch my node definition, but the agent run will continue:
Error: Failed to apply catalog: ReportEvent() failed: The parameter is incorrect."

Run out of ideas, looked at ssl certs, network, time sync, etc

Please point me what else i could check.

Thanks in advance!

Matt.
0
TegRND
Asked:
TegRND
1 Solution
 
Mohammed KhawajaManager - Infrastructure:  Information TechnologyCommented:
Check the puppet server certificate as to what the fqdn is (xxx.domain.local).  Check the Puppet config file and ensure the name is the same (it is case sensitive).  Restart the agent afterwards and try again.
0
 
TegRNDAuthor Commented:
Thank you for the suggestion, the issue was related to the master db.
0
 
Seth SimmonsSr. Systems AdministratorCommented:
This question has been classified as abandoned and is closed as part of the Cleanup Program. See the recommendation for more details.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now