Dell SonicWall SMTP out

Hi,
I have a Dell Sonicwall that I want to configure to allow the iLo port of an HP DL380e to send emails for notifications and such.  Can somebody tell me what steps I should take for best practices?  The ip of the iLo is 192.168.1.22.  
Also, when I'm VPN'd into the network, I can't RDP to any of the servers.  Can you provide the steps for that as well, as I'm sure they're similar but different.

Thanks!
JasonAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

carlmdCommented:
If you only want the HP to send outgoing mail, then you do not need to do anything to the Sonicwall. By default it will pass all outgoing traffic. All you would have to do is configure the HP to talk to whatever mail server you use.

As a part of the VPN configuration you have to declare what LAN networks the VPN connected devices have access to. You don't mention if you are using the SSLVPN or the IPSEC client.

For the SSLVPN go to SSL VPN -> Client Routes and use "Add Client Routes" to provide access. If you want to provide access to everything on the LAN, then it would typically be the LAN Primary Subnet. If something else, you might have to add an Address Object for it.

For the IPSEC client you provide access via the user login. Go to Users -> Local Users (assuming you did it that way) then select Configure and the VPN Access tab. Add the routes you want there.
0
JasonAuthor Commented:
Hi,
Thanks for the response!
I have tried the test email using the "Test Email" button but nothing comes through.  Email is not hosted internally so it has to go out to mail.xxxx.com.

Once I'm logged in via VPN, I can access all things on the network but RDP doesn't work.  It is enabled on the server.  I can ping and access shares and sql databases and such so I was thinking it had to be some port issues.  I did verify that it is still 3389 so I thought it had to be firewall related.
0
carlmdCommented:
From the hp try to "telnet mail.xxx.com 25". Do you get a response?

Assuming you are using the SSLVPN, on SSL VPN -> Client Settings under NetExtender Client Setting do you have NetBIOS over SSLVPN enabled?
0
How the Cloud Can Help You as an MSSP

Today, every Managed Security Service Provider (MSSP) needs a platform to deliver effective and efficient security-as-a-service to their customers. Scale, elasticity and profitability are a few of the many features that a Cloud platform offers. Register today to learn more!

JasonAuthor Commented:
It's an iLo port, I can't telnet or anything.
I'll check the netextender client setting when I get into the office.
0
carlmdCommented:
What version of iLo do you have? From what I read 2 and 3 may have an issue or need some type of special configuration. Version 4 seems to be simple. Are you sure you have the HP configured properly?
0
JasonAuthor Commented:
It is version 4.  I just have the AlertMail setup with the  email address, sender domain: domain.com, SMPT Port: 25, SMTP Server:  mail.domain.com.
No, I'm not sure I have it configured properly, that's why I'm here!  lol
What else, if anything, needs to be configured?
0
carlmdCommented:
Just some things I have found......

Make sure you have entered an Domain Name under Network -> iLO Dedicated Network Port -> General

Otherwhise your <Mail From> - Adress for AlertMail will look like <Hostname>.@<SenderDomain>
Note the point between <Hostname> and @, this will cause Exchange Servers (Exchane 2013) to discard Alert Messages from this sender.

If you enter an Domain Name  it just works fine.
Your <Mail From> - Adress will look like <Hostname>.<DomainName>@<SenderDomain>...

Also make sure to use the IP-Adress instead of DNS-Name of the Mail-Server if you have not defined any internal DNS-Servers in Network -> iLO Dedicated Network Port - IPv4 Settings .


Here is the manual, in case you don't have one.

https://www.webtropia.com/download/Manual_iLO4.pdf

Look at configuring alert mail settings on page 90.

I am assuming your HP is on the same network with other pc's who can send email. Given that, there must be something wrong the alert mail setup.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Evan HinesCommented:
first create your address objects.(your iLO interface) at this point.
second create service objects and group for iLO
service objects if I remember right are for the ports that iLO uses to communicate.
third create your Nat rule and finally create your firewall rule.
0
ravindragandhiCommented:
For Any Sonicwall Configuration/troubleshooting related task - you can drop e-mail to ravi@wellmarktechnologies.com
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Networking Hardware-Other

From novice to tech pro — start learning today.