Unable to install or uninstall Exchange 2013

I installed Exchange 2013 SP1 as the first and only Exchange Server on April 25th.  There were no previous Exchange servers on the domain.

I installed using the GUI after installing all of the prerequisite software. The installation produced no errors.

I was able to run EAc and I was able to access the Administrator mailbox from Outlook.  

I did not see the Exchange tasks in the Active Directory Users and Computers snap-in.  I did some research to try to figure out how to enable that functionality but had no success.

We were running a Server 2003 Domain Controller as well as a Server 2008 domain controller so I ran DCPromo to remove the Server 2003 domain controller.  This had no discernable effect.

On April 29th I decided to uninstall and reinstall Exchange 2013.  My plan was to run /prepareschema and /preparead from the command line prior to re-installing Exchange 2013.

The uninstall failed.  I tried again to uninstall but it failed again.  

The uninstall message suggested that I should try to run setup to re-install; which also failed.

The error message indicates that I'm not a member of the Enterprise Admins or Schema Admins groups.  I verified that my account is a member of those groups.  

I even created a new user and added that user to the specified groups.  Setup still fails.

I removed the server from the domain and rejoined it as suggested in one post.

Another suggestion was to ensure that my default group in AD was set to Exchange Admins versus Domain Users. No luck.

I have tried numerous times to run /prepareschema and /preparead with no success.

I believe that this information from the Technet website is relevant:

"If you're installing the first Exchange 2013 server in the organization, and the Active Directory preparation steps have not been performed, the account you use must have membership in the Enterprise Administrators group. If you haven't previously prepared the Active Directory Schema, the account must also be a member of the Schema Admins group. For information about preparing Active Directory for Exchange 2013, see Prepare Active Directory and domains. If you have already performed the Schema and Active Directory preparation steps, the account you use must be a member of the Delegated Setup management role group or the Organization Management role group."

I believe that the last sentence about being a member of the Organization Management role group is where the difficulty lies.  My theory is that setup is actually checking to see if I am a member of the Organizational Management group which I think is nonexistent and is returning a misleading error.


I downloaded CU8 and tried to run setup unsuccessfully.

This is what occurs when I try to run setup now.

C:\Users\GBRASWELL>d:

D:\>cd a*\x*

D:\Apps\xchg-CU8>setup /prepareschema /iacceptexchangeserverlicenseterms

Welcome to Microsoft Exchange Server 2013 Cumulative Update 8 Unattended Setup
Copying Files...
File copy complete. Setup will now collect additional information needed for
installation.
Languages
Management tools
Mailbox role: Transport service
Mailbox role: Client Access service
Mailbox role: Unified Messaging service
Mailbox role: Mailbox service
Client Access role: Front End Transport service
Client Access role: Client Access Front End service

Performing Microsoft Exchange Server Prerequisite Check

    Configuring Prerequisites                                 COMPLETED
    Prerequisite Analysis                                     FAILED
     The Active Directory schema isn't up-to-date, and this user account isn't a
 member of the 'Schema Admins' and/or 'Enterprise Admins' groups.
     For more information, visit: http://technet.microsoft.com/library(EXCHG.150
)/ms.exch.setupreadiness.SchemaUpdateRequired.aspx

     Setup encountered a problem while validating the state of Active Directory:
 Couldn't find the Enterprise Organization container.  See the Exchange setup lo
g for more information on this error.
     For more information, visit: http://technet.microsoft.com/library(EXCHG.150
)/ms.exch.setupreadiness.AdInitErrorRule.aspx

     The forest functional level of the current Active Directory forest is not W
indows Server 2003 native or later. To install Exchange Server 2013, the forest
functional level must be at least Windows Server 2003 native.
     For more information, visit: http://technet.microsoft.com/library(EXCHG.150
)/ms.exch.setupreadiness.ForestLevelNotWin2003Native.aspx

     A Setup failure previously occurred while installing the PreFileCopy role.
Either run Setup again for just this role, or remove the role using Control Pane
l.
     For more information, visit: http://technet.microsoft.com/library(EXCHG.150
)/ms.exch.setupreadiness.InstallWatermark.aspx

     Either Active Directory doesn't exist, or it can't be contacted.
     For more information, visit: http://technet.microsoft.com/library(EXCHG.150
)/ms.exch.setupreadiness.CannotAccessAD.aspx


The Exchange Server setup operation didn't complete. More details can be found
in ExchangeSetup.log located in the <SystemDrive>:\ExchangeSetupLogs folder.

D:\Apps\xchg-CU8>

ANy help will be greatly appreciated.
53tinAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Simon Butler (Sembee)ConsultantCommented:
"I did not see the Exchange tasks in the Active Directory Users and Computers snap-in.  I did some research to try to figure out how to enable that functionality but had no success."

First - you will never see Exchange tasks in ADUC - that was removed in Exchange 2007. All user admin goes through EMC or EMS.

Your server cannot see the domain. That usually means the network isn't configured correctly - wrong DNS etc.

Simon.
0
53tinAuthor Commented:
Simon,  Thanks for the info about the exchange tasks not being available in ADUC.



I believe that DNS is setup correctly.  The Exchange server can resolve names correctly. The Server 2008 R2 Domain controller is 192.168.0.8.  

Ipconfig on the Exchange server shows:
Ethernet adapter Local Area Connection 3:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Broadcom BCM5709C NetXtreme II GigE (NDIS
 VBD Client) #3
   Physical Address. . . . . . . . . : 00-10-18-93-CB-A4
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
   IPv4 Address. . . . . . . . . . . : 192.168.0.2(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . : 192.168.0.253
   DNS Servers . . . . . . . . . . . : 192.168.0.8
   NetBIOS over Tcpip. . . . . . . . : Enabled

This indicates that it sees the domain controller but can't find the Enterprise Organization container.

[05/11/2015 21:11:18.0091] [0] Setup is choosing the domain controller to use
[05/11/2015 21:11:24.0893] [0] Setup is choosing a local domain controller...
[05/11/2015 21:11:28.0497] [0] Setup has chosen the local domain controller ALHS-DC.Albones.com for initial queries
[05/11/2015 21:11:28.0606] [0] PrepareAD has either not been run or has not replicated to the domain controller used by Setup. Setup will attempt to use the Schema Master domain controller ALHS-DC.Albones.com
[05/11/2015 21:11:28.0606] [0] The schema master domain controller is available
[05/11/2015 21:11:28.0621] [0] The schema master domain controller is in the local domain; setup will use ALHS-DC.Albones.com
[05/11/2015 21:11:28.0621] [0] Setup is choosing a global catalog...
[05/11/2015 21:11:28.0637] [0] Setup has chosen the global catalog server ALHS-DC.Albones.com.
[05/11/2015 21:11:28.0653] [0] Setup will use the domain controller 'ALHS-DC.Albones.com'.
[05/11/2015 21:11:28.0653] [0] Setup will use the global catalog 'ALHS-DC.Albones.com'.
[05/11/2015 21:11:28.0668] [0] Exchange configuration container for the organization is 'CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=Albones,DC=com'.
[05/11/2015 21:11:28.0668] [0] No Exchange organization container was found for the organization. Message: 'Couldn't find the Enterprise Organization container.'.
0
Simon Butler (Sembee)ConsultantCommented:
Do you only have the one domain controller?
Personally I would download CU8, if you haven't already and extract it on the domain controller. Then run prep from there. Wait at least 30 minutes before doing anything else.

While waiting, use netdom query fsmo to ensure that all the FSMO roles are where you expect them to be, also check the domain controller is a global catalog.

The problems you have are more related to the domain, rather than Exchange. It is just Exchange is very dependant on AD, so will show up issues more than almost any other application.    

Simon
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
53tinAuthor Commented:
At this point there is a single domain controller.  There are four servers total, one of which is a Server 2003 R2 server running Sharepoint Services 3.0 for document management.

I tried CU8 but got the same error.  

You are correct that the issue is domain related.  i was hoping there was a magic bullet that someone could point to that would recreate the correct domain structure outside of the Exchange setup since it doesn't run.
0
53tinAuthor Commented:
Netdom shows all roles correctly assigned to the correct domain controller and it does contain the Global Catalog.

You are correct about it being a domain issue.  I think that I will open a question in the  Active Directory topic area.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.