cisco 3750 switch CLI help

I am not a CLI guru, but have stumbled around in it some.  I need to make changes to one switch port so that it is configured as the attached screenshot shows.  can some one give me the command(s) to accomplish this?
Doc1.docx
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Don JohnstonInstructorCommented:
This is strange... you already have the commands.

From privileged mode:

config t
int f0/2
 desc Port Facing Phone/Desktop/Phone+Desktop
 switchport trunk encap dot1q
 switchport trunk native vlan 1
 switchport trunk allowed vlan 1,2,1003-1005
 switchport mode trunk
 switchport voice vlan 2
 switchport priority extend cos 1
 no ip address
 spanning-tree portfast ! irrelevant since the port is a trunk. Should be:
 spanning-tree portfast trunk
end
copy run start

Open in new window

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
RafaelCommented:
I would concur with Don. My only concern would be  what version of IOS you're running. Outside of that it should all work.

[i]HTH
-Rafael[/i]
StolsieCommented:
^yip what they said
Powerful Yet Easy-to-Use Network Monitoring

Identify excessive bandwidth utilization or unexpected application traffic with SolarWinds Bandwidth Analyzer Pack.

allgoodusrnamesaretakenAuthor Commented:
thanks guys, told you I wasn't very good at this.  one last question and I will be making the change later today.  below is the actual switch and port i'm changing, in Don's reply he used the interface I had used in my attachment "int f0/2", but will it be "int ge4/0/17" in my case?

interface GigabitEthernet4/0/17
 switchport mode access
 switchport voice vlan 2
 spanning-tree portfast
Don JohnstonInstructorCommented:
Correct.  Just substitute "g4/0/17" instead of whatever I put in.
RafaelCommented:
Missing a space so "interface GigabitEthernet 4/0/17"
Don JohnstonInstructorCommented:
Missing a space so "interface GigabitEthernet 4/0/17"
Huh?
StolsieCommented:
He is just referring to your example you didn't have a space between the "t" in Gigabit and the interface "4".

A little crash course for you in CLI
if you type "int" then press "tab" it will finish the word for you if there is no other option (like in Linux)
It you type "int" then press "?" in will display possible options beginning with "int"
Once you are familiar with commands you don't even have to type them out fully
So
Interface GigabitEthernet 4/0/17
Becomes
int gi 4/0/17
Don JohnstonInstructorCommented:
He is just referring to your example you didn't have a space between the "t" in Gigabit and the interface "4".
There is no requirement for a space between the interface type and the module or switch number.
Switch#config t
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#int g1/0/1
Switch(config-if)#
Switch(config-if)# gigabitEthernet1/0/2
Switch(config-if)#

Open in new window

StolsieCommented:
I mistook your comment for the OPs, if i had noticed i wouldn’t have said anything.
My bad
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Switches / Hubs

From novice to tech pro — start learning today.