RDS RemoteApp isn't connecting properly.

We have a terminal server that has remote app configured and we have an SSL certificate for the external name. I have changed the terminal server name under the connection settings under "RD Session Host Server" to the external domain name. When I attempt to connect though, it shows the external domain name, however it pops up prompting for a password to connect to the internal server name. We enter the username and password and it does not take it, it pops up again. The weird part is, This has worked on a laptop outside the office, and one other PC, but nothing else we've tried works.
absinternetAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Brett DanneyIT ArchitectCommented:
Try entering the username as external_server_name\username.
0
absinternetAuthor Commented:
That did not work unfortunately. The weirdest part of all is that, again, this has worked on two computers. Not sure what is different about those. I am able to log in, I select "this is a private computer" but when I launch the app, I get another prompt to log in to the local system name but it never accepts any credentials I put in.
remote-rds.png
0
absinternetAuthor Commented:
just tested it again, and now it's not working anywhere now.
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

absinternetAuthor Commented:
I have even tried adding remoteapp directly in windows 8 control panel. I can't get around the credentials window from popping up, and typing correct credentials and it not allowing me in.
0
absinternetAuthor Commented:
Solved it, Turned out HTTP redirect was enabled on the default page. Disabled that, and presto chango. Just make sure that box is disabled and use a simple HTML redirect script in the default or index page. That stopped the pop-up box for credentials from constantly popping up.  resolution.png
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
absinternetAuthor Commented:
The issue was to disable HTTP redirect
0
absinternetAuthor Commented:
Someone else did comment yes, but it was not near the resolution.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2008

From novice to tech pro — start learning today.