RDS RemoteApp isn't connecting properly.

We have a terminal server that has remote app configured and we have an SSL certificate for the external name. I have changed the terminal server name under the connection settings under "RD Session Host Server" to the external domain name. When I attempt to connect though, it shows the external domain name, however it pops up prompting for a password to connect to the internal server name. We enter the username and password and it does not take it, it pops up again. The weird part is, This has worked on a laptop outside the office, and one other PC, but nothing else we've tried works.
absinternetAsked:
Who is Participating?
 
absinternetAuthor Commented:
Solved it, Turned out HTTP redirect was enabled on the default page. Disabled that, and presto chango. Just make sure that box is disabled and use a simple HTML redirect script in the default or index page. That stopped the pop-up box for credentials from constantly popping up.  resolution.png
0
 
Brett DanneyIT ArchitectCommented:
Try entering the username as external_server_name\username.
0
 
absinternetAuthor Commented:
That did not work unfortunately. The weirdest part of all is that, again, this has worked on two computers. Not sure what is different about those. I am able to log in, I select "this is a private computer" but when I launch the app, I get another prompt to log in to the local system name but it never accepts any credentials I put in.
remote-rds.png
0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

 
absinternetAuthor Commented:
just tested it again, and now it's not working anywhere now.
0
 
absinternetAuthor Commented:
I have even tried adding remoteapp directly in windows 8 control panel. I can't get around the credentials window from popping up, and typing correct credentials and it not allowing me in.
0
 
absinternetAuthor Commented:
The issue was to disable HTTP redirect
0
 
absinternetAuthor Commented:
Someone else did comment yes, but it was not near the resolution.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.