Sharing folder - Windows Server 2012 Essentials - non-domain environment

Hi - We have a new Windows 2012 Essentials server in a non-domain environment and I'm trying to set up a shared folder so that anyone in our school can access this shared folder without having to enter any credentials, and it doesn't seem to be working. Initially I set it up on the data drive (D), right click/properties/sharing and chose everyone with full control. If I go to a computer within the network and do a start/run -  \\abcserver it asks me for a username and password. Then, after reading that in order for this to happen, without making everyone have to use credentials, the shared folder needs to be placed and shared in the public profile on the server. I did that, but its still asking for a username/password. Any help would be greatly appreciated!
hodgemAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Brett DanneyIT ArchitectCommented:
Go to the folder you want to share. Right click and go to properties.
Under the sharing tab click the Advanced Sharing button.
In the advanced sharing window click the permissions button. The everyone group should be added there and full control, change and read should be allowed.
(I think you have done this all already)
Next step go to the folder you want to share. Right click and go to properties again.
Under the security tab click the edit button.
On the permissions for system you need to select a local group on the server that all users belong too, and grant modify permissions. This group could be users, or guest, or you could even create a new local group. The important bit is that the user is a member of this group.
0
hodgemAuthor Commented:
Thanks for your reply. The thing is, this is a non-domain server and there are no users setup on the server (except for administrator) to even add to a group. This is a new server that was added to a non-domain environment.
0
Peter HutchisonSenior Network Systems SpecialistCommented:
You may need to enable the 'Guest' account to allow users access to shares without using their own credentials.
Use Computer Management admin tool to enable it.
0
The 7 Worst Nightmares of a Sysadmin

Fear not! To defend your business’ IT systems we’re going to shine a light on the seven most sinister terrors that haunt sysadmins. That way you can be sure there’s nothing in your stack waiting to go bump in the night.

Brett DanneyIT ArchitectCommented:
As Peter said enable the Guest account.
The Guest account is a member of the Guest group, add the Guest group to the permissions for system.
0
hodgemAuthor Commented:
ok how do I add the "guest group" to the permissions for system?
0
Peter HutchisonSenior Network Systems SpecialistCommented:
The Everyone group includes guest users and groups.
0
hodgemAuthor Commented:
Ok now I'm completely confused. Would you be able to provide step by step instructions? Just not sure how to add the guest group to the permissions of the folder we want shared, it seems like it would be simple, but I think I'm missing something.
0
Peter HutchisonSenior Network Systems SpecialistCommented:
1. Open properties of the folder
2. Select Sharing tab, enable sharing (if not already done).
3. Select Permissions button
4. Click Add
5. Change Location to name of server
6. Type in 'Guests'
7. Click OK
8. Change permission to Read and Change.
9. Click OK
10. Click On Security tab
11. Click on Edit
12. Add the Guests group
13. Select Modify
14. Click OK
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
hodgemAuthor Commented:
Ok, so i did exactly as described above giving the guest group read/change permissions to the folder we'd like to share and I'm still getting prompted for a username/password. Any other ideas?
0
hodgemAuthor Commented:
Hi - just checking in again, is there something I'm missing? I checked and everything seems to be set correctly any other reason why it would be prompting for username and password to shared drive?
0
Peter HutchisonSenior Network Systems SpecialistCommented:
Is Everyone group added as well, so you include Anonymous access?
0
hodgemAuthor Commented:
Yes - the everyone group was the first group added to the folder access
0
Peter HutchisonSenior Network Systems SpecialistCommented:
Hum, not sure where to go from here.
Are the PCs and server in the same Workgroup?
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2012

From novice to tech pro — start learning today.