ESXi 5.0 time problem

I've got an ESXi 5.0 host with time issues.  This particular host has two guest VMs, a terminal server (Server 2008) & a Window7 VM used for backup.  The terminal server users started reporting odd issues.  When I looked into it, the OS time was off by about 20 minutes.  The VM Host time was also off by about 20 minutes.  I figured the BIOS time was off, shut the server down and booted to the BIOS.  The BIOS time was off by several hours.  I set the BIOS time to the correct time and booted up the host.  How the guest OS times are off by 4 hours, as is the host.  The odd thing is that when I manually change the host time, using the vSphere Client, the host disconnects me.  I then have to reboot the host to get access.  

If I manually change the guest OS time, the guests are still acting funny.

Any idea on how I might be able to fix this?  Possibly get the guest OS to just look at the domain controller for the time instead of the host?  The terminal server is basically unusable while this is happening, so any help would be appreciated.

Thanks very much.
SupermanTBAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

dmwynneCommented:
Set the VMware host with correct time:

http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1318   


In AD domains all servers and workstations should be set to use domain hierarchy to get their time. The PDC Emulator DC however is a special case and should be the only one set to sync from an external time source.

https://technet.microsoft.com/en-us/library/dd723673%28v=ws.10%29.aspx (the best practice)

VMware’s Article says not to enable time sync through the tools:
 
https://www.vmware.com/files/pdf/solutions/Virtualizing-Active-Directory-Domain-Services-on-VMware-vSphere.pdf
0
SupermanTBAuthor Commented:
I've read most of those articles already.  That first KB article suggest making registry changes in the guest OS and also changes on the host.  Are both of these required?

I'm in a bit of a jam and could use some very specific help.
0
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
We recommend the following:-

1. Sync ESXi Host time with External Time Source e.g. internet if available or GPS time clock.

2. Sync Windows Acitrve Domain Controller PDC emulator with the same time source in 1.

3. Any Linux or Unix VMs sync with time source in 1.

4. All Windows VMs will sync with Active Directory.

5. Disable Sync with host in Windows VMs.

6. Disable Sync with host in Linux VMs.

7. Set host time in the BIOS of server, to within 1 minute of internet time!
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

SupermanTBAuthor Commented:
Thank you for the assistance Andrew.  Regarding the first step, I want to make sure I have the correct steps:

On the host, go into Time Configuration, check the box saying NTP Client Enabled, click the options button, select Start and stop with host.  Go to NTP settings and add a server.  Do i have that correct?  Do you know of a good server to use?
0
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
Yes, that's the correct steps.

based on your location go here...

http://www.pool.ntp.org/en/
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
SupermanTBAuthor Commented:
Ok, so I entered the us.pool.ntp.org as I am in the US.  I've entered everything as described and the host time is still off by several hours.  I have not restarted the host yet.
0
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
I believe, that the time difference must be close for a sync, otherwise it will not sync.

hence Step

7. Set host time in the BIOS of server, to within 1 minute of internet time!
0
SupermanTBAuthor Commented:
After doing this and restarting, the issue was fixed.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
VMware

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.